1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

What is wrong with my plow?

Discussion in 'Western Plows Discussion' started by PremierLand, Nov 5, 2007.

  1. PremierLand

    PremierLand PlowSite.com Addict
    from detroit
    Messages: 1,572

    I have an 2000 Western 8.5ft plow. Im not sure if its a unimount or ultra, because it hooks up the exact same way as my 06 ultramount does, but it only has 2 wiring harnesses.

    Anyway, I put it away last year and it worked fine, I just needed a new controller because the pump would run for a few seconds afterwords, but not much. But like I said it worked fine when I Put it away. I hooked it up this weekend and it worked fine, up/down/left/right, execpt a few times once it was down it wouldnt move, but the selinoid would still click. Then today I went to hop in the truck to make a delivery and the plow wouldnt move again, just clicking and the pump wasnt running either. It has fluid also.

    Any ideas?
  2. 6feetdeep

    6feetdeep Senior Member
    Messages: 141

    Sounds like bad brushes in the pump motor. Probably needs rebuilt or replaced.
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If the under hood solenoid is clicking but the motor isn't running then it's either a poor connection between the motor and the battery on the power wire, or a poor connection on the ground side. Use a set of jumper cables (use both power and ground clamps of course) and run power from the battery directly to the motor to see if the motor now runs..if it does then you have a poor connection somewhere. If it still dosen't run, then the motor or brushes are worn.
  4. Midwest BuildIt Inc

    Midwest BuildIt Inc PlowSite.com Addict
    Messages: 1,280

    sounds like its broke!!!:waving:
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    I've seen bad 12volt motor solenoids that would click but not transfer energy. Test the in and out from the 12v Sol. You can stick the test light in the battery ground terminal and attach the ground clip to the out on the 12v sol. (this will allow you to test this yourself) then try to raise it and see if the test light lights.

    You could also try playing with the grill plugs, those molded rubber plugs do love to rot internally.
  6. 6feetdeep

    6feetdeep Senior Member
    Messages: 141

    I, too have seen solenoids that 'Click', but do not actually make full contact inside. I had one on my Ferris mower this summer, found out that there was not enough 'Juice' to the activation wire, solenoid would try to work, but wouldn't move enough inside to make a good contact. didn't think of that in my first post.
  7. PremierLand

    PremierLand PlowSite.com Addict
    from detroit
    Messages: 1,572

    It ended up being the selinoid.

    while i was at it I cleaned up the power and ground at the pump.

    thanks guys
  8. Philbilly2

    Philbilly2 PlowSite Veteran
    Messages: 3,767