1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western UniMount

Discussion in 'Commercial Snow Removal' started by glenspot, Dec 26, 2004.

  1. glenspot

    glenspot Senior Member
    Messages: 255

    Western UniMount

    Had this problem late last week. Easy solution, but baffled me for a while. Maybe this story will come up in a search sometime for other Western Users.

    On a very cold day, I plowed early in the morning. Parked my truck outside of my day job. At 1:30pm...came out started the truck. Tried to raise the plow... and strange things happened. Plow didn't respond. The "high beam" and left turn signal lights lit on the dash. And the solenoid didn't click. Also, the red "on" indicator on my controller was "on" whether i turned the switch on or off.

    I unplugged the 2 pin connector and the 9-pin connector. Unplugging the 9-pin plug seemed to reset the system to normal. But returned to a screwed up state as soon as I tried anything with the controller.

    I knocked the snow off the connectors, unplugged them and blew in the them to get any "stuff" out of them with no luck. Checked all fuses, connections, etc

    Finally I took out my leatherman to see if one had broken loose or something. Nothing seemed loose. All was tight and secure. I then used the leatherman to sort of "clean" the metal ends in the connectors. That did it.

    Plugged it back in, and everything worked great. Plow began working, lights worked....everything was back to normal. Apparently Some moisture had gotten in there and perhaps frozen, to create a "film" that prevented the electrical connection.

    When things were all put together, I used dielectric grease, but with moisture must have gotten in there.

    Anyway. Maybe this thread will come up if someone searches for Western Unimount Problems or something.

  2. stumper1620

    stumper1620 Senior Member
    Messages: 222

    thanks glen
    i've got a western ultra with the same plugs, if i have anything goofy going on i'll know where to start, thanks again
  3. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    Might try the grease and a shot of WD40 each time you connect. The WD40 repels moisture so maybe it would help. I had an 75 year old uncle that swear-ed by WD40 for problems like this.
  4. Tom Smith

    Tom Smith Senior Member
    from IL
    Messages: 149

    I have a new western mvp plow.... Western recommends that you apply western die electric grease to the connections after every use of the plow. The stuff is real cheep and it keeps all the corosion and moisture off the plugs.
  5. LINY Rob

    LINY Rob Senior Member
    Messages: 478

    western throws in like 4 tubes of that grease, but god forbid you should get some fluid thrown in instead of having to pay extra for it :nono:
  6. cet

    cet PlowSite Fanatic
    Messages: 7,257

    I don't want to rock the boat, but never use WD40!
  7. NU-Plowr

    NU-Plowr Member
    Messages: 36

    Makes an unbelievable difference...
  8. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    I noticed the a couple of days ago that AutoZone's selling a lot bigger tubes of the grease then they used to. For once the price of something we use a lot of seems to have dropped!
  9. ptllandscapeIL

    ptllandscapeIL Senior Member
    Messages: 495

    never use wd-40 is corect use somethign with a silicone base like dupoint teflon or somethign of that sort..