1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Western Unimount now turning right instead of lifting up?

Discussion in 'Introduce Yourself to the Community' started by NewtothePlow, Dec 5, 2011.

  1. NewtothePlow

    NewtothePlow Junior Member
    Messages: 10

    I have a post or two about this and the solenoids? I am fairly new to this...and new to an electric plow. I have the joystick control on a pro plus. When I first hooked the plow it lifted, moved right and left, and dropped (way too fast by the way). I put this in my shed to work on...pushed the plunger down all the way to check fluid level....went to lift the plow with the joystick and it just clicked...tried again and saw a puff of smoke from the motor relay area. Then nothing. Replaced relay and still nothing. So I jumpered the relay and it moved right. Replaced relay and this time is worked with the joystick...but moved right again when I pushed up...and then it blew my hose on the left cylinder. I'm going to replace both hoses and I am guessing a solenoid as well?:help: Thanks
  2. Philbilly2

    Philbilly2 PlowSite Veteran
    Messages: 3,797

    doesnt quite make sence. went you request up, the S3 is the only valve that should move. That is also used for left.

    Which way are you speaking from, in front of the truck or in the drivers seat?
  3. Philbilly2

    Philbilly2 PlowSite Veteran
    Messages: 3,797

    forgot to tell you that you can ajust the way to fast by turning the quill

  4. NewtothePlow

    NewtothePlow Junior Member
    Messages: 10

    Sitting in the drivers seat, moving the joystick to raise the plow turned it right.
  5. Philbilly2

    Philbilly2 PlowSite Veteran
    Messages: 3,797

    I believe that your S2 is still stuck open. More or less, you need to pull the valves and clean them or replace it.

    You can test them by pulling them out of the block of the plow and putting the coil back over it and activating the coil to look and see what is happening. Somtimes there can be a metal shaving or debris in the vavle that will not allow it to open or close properly. If you clean or replace them, you willl fix the problem.
  6. rywnygc

    rywnygc Member
    from 14033
    Messages: 99

    I had this problem with a Western Ultramount. I took it in to the dealer after trying to figure it out on my own. It ended up being a bad ground. They fixed it in about 20 minutes, once they found the issue.
  7. LaytonTruck

    LaytonTruck Junior Member
    Messages: 27

    I have to agree with relee check you grill connection and make sure the relay is grounded well. Clean the connection at the grill and re-apply Die electric grease to them.If the plow is older could possibly be a controller I have seen that before.
  8. wideout

    wideout Senior Member
    from iowa
    Messages: 727

    I agree with these guys to my unimount did the same thing and it ended up being my ground . cleaned the batteries and wires and it worked fine after that
  9. NewtothePlow

    NewtothePlow Junior Member
    Messages: 10

    I anticipated part of the problem might be connection or ground. So, I made sure the battery was cleaned up and dielectric grease was put on all electrical connections before I ever attached the plow. However, I did removed the cover for the coils and those look to have a bit of corrosion. I haven't had an opportunity to shine those connections up but maybe, just maybe, that will help too?
  10. Philbilly2

    Philbilly2 PlowSite Veteran
    Messages: 3,797

    corrosion is never a good thing. cant hurt to clean it up