Snow Plowing Forum banner
1 - 20 of 36 Posts

· Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
thank you for reading

latest sweet breakdown is the motor keeps runnign and doest shut off after i go any direction. then the entire truck loses all power so I have to unplu the plow and after a few it starts back up. it kills the trcu kdrawing for the motor and never shutting off. w i t f . new motor this week btw. last gave out after constantly runnign.
when i unplug the 6 pin harness fishstik it stops. . if i unplug the 9 pin at the plow it doesnt.

Could this be a bad ground? or does it have to be the controller or the solenoid>
what is the black and orange wire i nthe harness goign to the selenoid? theres 2 little wires and one is on the selenoid.
 

· Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
If the motor stays running and you unplug the controller, replace the controller. But I would also replace the solenoid, they are not designed to operate that long. And they are not expensive.
the controller is 600 dollars and seems to work fine. i feel like its the solenoid, do both the little wires from the controller need to be hooked up? one is maybe a ground relay? my motor relay didn't have a place for it. but it worked for a long time just fine . at least i thought.could it be from just a bad main ground pin? That harness is whooped.
 

· Registered
Joined
·
14,949 Posts
Bird is that you?
 

· Registered
Joined
·
14,949 Posts

· Registered
Joined
·
14,949 Posts
And it was working?
 

· Registered
Joined
·
14,949 Posts
Get a new solenoid for a plow, and then start looking for a new controller
 

· Registered
Joined
·
14,949 Posts
1 - 20 of 36 Posts
Top