Western Isarmatic Mark III cable driven issue

Discussion in 'Western Plows Discussion' started by coleallen, Oct 7, 2019.

  1. coleallen

    coleallen Junior Member
    Messages: 2

    Hey everyone, I've got an old school cable driven plow that I am having issues with. It's an older model, not even sure how old, it came on a 78 bronco I bought. 2 seasons ago, it quit angling to the right. I dont remember if this occured before or after I went through the pump, cleaned and replaced a few parts. I have replaced the check valve assembly twice. When I say it quit to the right, I should say, it goes up when I try to angle right. From what I've read in the trouble shooting section it says to adjust the lift valve. I'm not sure which way to run the valve. Right now I feel it runs great up and down. I am also gun shy to keep running the valve in and out, as its plastic and the head likes to strip(had to replace it twice as well). Is that legit the lift valve that is the issue, and anybody have a better explanation to adjusting because right now the lift valve is sitting flush with the housing.. TIA
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 13,147

    Look at your 4 way valve..

    Screenshot_20191007-195926_Drive.jpg

    Screenshot_20191007-195915_Drive.jpg
     
  3. OP
    OP
    coleallen

    coleallen Junior Member
    Messages: 2

    Are you thinking maybe the check ball isn't stopping flow to the lift ram?
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 13,147

    No, the 4 way is not shifting
     
    Randall Ave likes this.
  5. Avalanche 2500

    Avalanche 2500 Senior Member
    Messages: 673