1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

V plow controller stopped working

Discussion in 'Boss Plows Discussion' started by plowboy87, Nov 18, 2015.

  1. plowboy87

    plowboy87 Senior Member
    Messages: 310

    Desided to hook the plow up, turned the controller on, backlight was green. I raised the plow up and then turned the controller off when I went to turn it back on light wouldn't come on or any buttons work. Checked fuse and power. I have power coming out of the on/off switch but still no movement when I hit the controller. Only two seasons on this controller. Any thing else to check?
  2. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,779

    Wiggle the tag line into the fusebox for your controller.
  3. Jaynen

    Jaynen Senior Member
    Messages: 309

    Ground wire?
  4. plowboy87

    plowboy87 Senior Member
    Messages: 310

    well I have power coming out of the switch to the black little box with all the wires on it. (Inside of controller) but not sending power passed that to send power to the plow. Hopefully that makes since.
  5. k1768

    k1768 Senior Member
    from NJ
    Messages: 556

    My straight blade controller did the same thing a couple of years ago. My bad luck it died during an event. I was able to get a new one that night. I ordered a new pcb for the old one, that fixed it.
    I now use the old repaired one as my primary and the new stays in my truck as a spare.
  6. maxwellp

    maxwellp PlowSite.com Addict
    Messages: 1,123

    Hook up the back up controller - Or it is time to get a back up controller.
  7. plowboy87

    plowboy87 Senior Member
    Messages: 310

    Update. Well i noticed my truck lights wasn't working, but the plow lights would. So I found a loose connection in my headlight adapters. Fixed that problem. So I used my backup controller and everything works fine. Now I desided to plug my hand held controller back in one last time to see if it would work, everything lit up and worked. So I guess this thing has a mind of it's own.