1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Updated body control module for voltage spikes

Discussion in 'Ford Trucks' started by dlcs, Dec 22, 2016.

  1. dlcs

    dlcs 2000 Club Member
    Messages: 2,160

    My western dealer contacted me today and sent me this release. Ford has a Service bulletin out on the voltage spike problem while operating a plow.
     

    Attached Files:

  2. tawilson

    tawilson Senior Member
    Messages: 225

    Thank you for that. I will be contacting my dealer.
     
  3. dlcs

    dlcs 2000 Club Member
    Messages: 2,160

    No problem. Just got the update so far so good but haven't plowed or worked it hard yet. Time will tell.
     
  4. reedo

    reedo Member
    Messages: 35

    It states for 2015-2016 vehicles. I have a 2013 F-350 gas that's been doing this since day one.
     
  5. dlcs

    dlcs 2000 Club Member
    Messages: 2,160

    Didn't help, still does it.
     
  6. reedo

    reedo Member
    Messages: 35

    I have an appointment next Thursday. I will report back whether I have luck or not. The last 3 times in I got no help but that was before the bulletin.
     
  7. dlcs

    dlcs 2000 Club Member
    Messages: 2,160

    Yes please let me know how it works for you. Thanks
     
  8. reedo

    reedo Member
    Messages: 35

    I took my 2013 F-350 in yesterday after seeing this bulletin. I was told this is only for the 15' and 16' model years because they have a different ECM. They had a 2017 in there with the same problem and they were unable to get that fixed also! So I guess if you have anything besides a 15' or 16' you are outta luck.
     
  9. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 12,174


    Interesting on the 17...... Nothing is the same on the 16 and earlier models.

    Technology in the 17 is so far advanced, crazy jump from the 16.

    Either way with 5 plowing, my has been flawless.
     
  10. tawilson

    tawilson Senior Member
    Messages: 225

    My 15 is okay as long as I turn on as many electrical gizmos as possible. I'll be taking it in for the update sometime this month.
     
  11. tawilson

    tawilson Senior Member
    Messages: 225

    Got it done. Didn't fix the problem. The flash screwed the truck up and the dealer had to keep reflashing. Several hours later the truck was back to normal. I wouldn't recommend this fix.
     
  12. Mark Oomkes

    Mark Oomkes PlowSite Fanatic
    Messages: 13,239

    So Chebbie and Furd have this same problem. Haven't heard of it in RAM's. I wonder what they did different.
     
  13. reedo

    reedo Member
    Messages: 35

    From what I am told all manufacturers have this problem.
     
  14. Mark Oomkes

    Mark Oomkes PlowSite Fanatic
    Messages: 13,239

    And yet no threads for RAM owners. I know I'm not the only one running a newer RAM. And I couldn't find anything on Google.
     
  15. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 12,174

    They are not as technically advanced, they are also the minority......

    Or they got their stuff figured out.....lol
     
    reedo and Mark Oomkes like this.
  16. Hysert

    Hysert PlowSite.com Addict
    Messages: 1,676

    I would assume this could be the reason after our push on Sunday I got into my 16 on Tuesday and all my radio settings were gone? I don't drive that one so will ask my foreman!