1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

UniMount Won't go Down and won't stay up

Discussion in 'Western Plows Discussion' started by ssanchez, Jan 1, 2013.

  1. ssanchez

    ssanchez Junior Member
    from Selkirk
    Messages: 2

    Ok so i bought a relic a 1987 F350 6.9L Diesel with an 8foot Western Unimount Isarmatic III on it.
    It wasn't behaving correctly and i wanted it to work for the season so i brought it to T&T Body King in NY who pretty much owns the market in our area for Western, Fisher etc..

    They Charged me $1018 - i got
    • Torsion SPring
    • Lift Ram Kit
    • Pro Dex/Merc III Fluid
    • New Spring
    • 2 Hitch Pins
    • 2 Hose
    • 2 1/4" Quick Cupler
    • Motor Relay Kit
    • 2" Packing Set
    • 2" Wiper Set
    • Ram Assembly 1 1/2 x 10 Kit
    • Clevis Pin
    • New Controller Cable and
    • 2 Western Blade Guides
    • with 6 hours labor.

    They did a lot of work and when i left it was working ok - granted it is old and i use it for rentals and my own home -

    Well it started doing some strange stuff right away - struggling to go up - lights dimming etc..
    Got on this board and did some homework and looked at the possibility of a power issue so i spared no expense and got new Alternator and new batteries - I have a two battery system without an isolator.

    Shortly after doing that - the plow was refusing to go up without help - if someone was in the cab and pushed the up on the control another person could lift the plow and it woudl stay - drive around a bit and do some plowing and all of a sudden it would come back up and start working sometimes - no rhyme or reason why.

    Than this morning i went outside and the plow not only wouldn't go up - it wouldn't stay up even if we lifted it - it fell down.

    I unchained the plow and worked the controls and the lift ram went up - no problem without the plow attached. I could push it down and do whatever but as soon as i attached the plow - it did nothing - NOTHING. Makes noise wants to do something but nothing is going on.

    Moves right and left just fine and everything else is just fine but up is a NO.

    Any ideas - I have not swapped out electrical cables but i cleaned and wire brushed everything and checked everything really good - it all looks ok - the Alternator is putting out 14-14.5 amps - the batteries were fully charged this morning - before i started playing with the up down problem - brand new (less than 2 days old) alternator 105amp and batteries 2 850cca batteries. I do not run lights or heat and have no other extras - i don't even turn on the radio. When i experienced the dimming i was running all the lights plow and regular and heat full blast and the radio and a roof strobe - since then i have stopped all that replaced alternator and both batteries (in the last week) and the dimming went away but the plow still won't go up

    Help me please - it is starting to get really frustrating.

  2. JohnnyU

    JohnnyU 2000 Club Member
    Messages: 2,040

    If it will angle fine while on the ground, but not lift, check your fluid level. It honestly sounds like you are low on fluid.

    The angling function displaces no fluid from the reservoir as you are basically returning the fluid from one cylinder as you are pumping into the other. Raising the blade uses fluid from the reservoir to fill the lift cylinder. If there is not adequate volume in the reservoir, it cannot pressurize and fill the lift cylinder.
  3. ssanchez

    ssanchez Junior Member
    from Selkirk
    Messages: 2

    Thanks John.
    When they serviced it last week - they flushed and replaced all the fluid - all of it.
    I assume the levels are ok since i am not leaking.

    I am doing some additional electrical research seems to show that the motor should be grounded to engine block and not connected to the (-) negative on the battery -

    Does anyone know if this could cause a problem.

    The motor has 2 wires going to it one positive (+) from relay solenoid and one negative (-) from battery to motor.

    The schematic seems to show this as a + from solenoid relay and black ground to engine block - could this be an issue - i am so freaking lost on this.

    Last edited: Jan 1, 2013
  4. JohnnyU

    JohnnyU 2000 Club Member
    Messages: 2,040

    Steve, I would still check the fluid level just to make sure that it was bled properly after the dealer flushed the system. If there was air in one of the angling cylinders that worked its way out while operating it would cause the level to drop and result in very similar symptoms to what you are describing (Worked ok at first, then started having the lift issues).
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,392

    yes ck your fluid.....but i might be thinking a pump psi test is in order. if its an older plow. the original owner might hae ran tranny fluid through it and western would have put blue in there. 2 totally different viscosities.
    the gnd comment,,,,as long as you have a GOOD clean and solid connection you can goto the frame, engine,etc. the problem that happenes it the they slowly get corroded and stop contucting electricty, and stop working.
  6. #1 plowtech

    #1 plowtech Senior Member
    Messages: 253

    6 hours labor!! seriously!
    your getting ripped off my friend

    That should of been 2 hours
  7. JohnnyU

    JohnnyU 2000 Club Member
    Messages: 2,040

    How did you make out, Steve? Have you resolved your issue?
  8. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Sounds like the system has lot of air trap. Probably what they did was

    A) Raise the plow instead of manually turning the plow from left, to right forcing the air out of the system.

    B) when they repack the lift arm, they probably didn't have it all the way down before they fill the unit

    If it was me, I would put a piece of 2x4 (short piece) under the blade (center, and making sure the lift arm is all the way down). swing the blade manually from left, wait about 30sec, then swing it to the right, then wait another 30sec and center the blade. Check the fluid to make sure it is full, then try to raise it. If it does raise, I would then swing it to the right (using the controller) then to the left, lower the plow (making sure once again the lift arm is all the way down) and recheck the fluid.

    Hopefully they check the screen and change it as well !!!

    Lot of time spent on the plow??

    I also see you had "New controller cable". If this is a cable instead of a joy stick controller, wonder if the cable is out of adjustment?
    Last edited: Jan 9, 2013