1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

unimount pump runs (squeels), nothing happens

Discussion in 'Western Plows Discussion' started by Silverstreak, Feb 20, 2011.

  1. Silverstreak

    Silverstreak Senior Member
    Messages: 168

    suddenly one of my plows stopped working, the motor will run and screech (doesnt sound to be under a load) almost sounding like it was out of fluid, the plow lowered ok but wont raise or angle

    checked and double checked my connections, sandblasted my connectors at the grill

    took off my battery cables and wirebrushed all of those

    took a pair of jumper cables to be sure i was getting a good ground at the valve block (black/orange wire seems ok)

    also...took a jumper wire and jumped all 3 valve coils, one at a time, and still no movement

    took off the motor drained what i thought was pretty clean fluid, checked the screen, blew it clean for good measure

    last thing i have done was cut off the grill connectors and spliced them direct, still the same problem, motor runs and squeels at a good rpm but nothing moves

    any helpful ideas? thank you!
  2. theguynextdoor

    theguynextdoor Senior Member
    Messages: 308

    The same thing happened in both of my plows. There was water in the fluid which froze in the system somewhere. I drained it, took the hoses off, emptied the pistons and the problem was solved. Water was getting in at the top of the lift piston, where the packing seals were bad. It was just as you said, where the motor would run and the pump would sound like it was out of fluid, but the plow wouldn't angle or go up at all.
  3. Silverstreak

    Silverstreak Senior Member
    Messages: 168

    ill check it out again.....its been 65 degrees all week, i thought it was ice at first and left the plow until it thawed out thanks for the quick reply!
  4. mishnick

    mishnick 2000 Club Member
    Messages: 2,353

    When you hot wired your coils you say there was "no movement", was that that no movement of the plow or no movement in the valves? When you put power to the coils (if they are on the valve) you should at least hear the valve click. Only one valve will do anything without the motor turning and that lets the blade down.

    Is this a straight blade uni or a v plow?

    Since your motor still works but the controls are all failing I suspect a broken common wire . Since I don't know what kind of plow it is I can't look up the schematic but I can tell you that there is either a common + going to all the coils or a common ground. Another possibility is that the controller is failing.

    Identify the exact plow model you have and we can pull a schematic for you.
  5. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    If you have a unimount, check the orn/blk at the solenoid to make sure it clean and secured..There should be a blk/orn either attach to the plow frame or the plow motor.. This wire is the ground for the relays and the plow lights.. Make sure it is not broken, clean, and attach secure.. Also check the brn/red wire attach to the solenoid to make sure it is also clean and secured..

    Might be possible, you might have a bad pump..
  6. Silverstreak

    Silverstreak Senior Member
    Messages: 168

    it was that damn s3 valve, musta gotten stuck with junk, took it out and worked it with an awl a few times and now its fine,

    now im upset i cut off my grill connectors for nothing!!
  7. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Good job........Glad you solve the problem

    As for the grill connector, I would be to...I would of use a test light...Everyone is entitle to make mistakes....No one is perfect, not even me.....But some think they are.........

    Safe plowing....
  8. PabstBlueRibbon

    PabstBlueRibbon Senior Member
    Messages: 733

    If the pump runs but does not work its mechanical. If you get nothing its electric. Basic trouble shooting right there
  9. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683


    problem has been solved.........