1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount MVP won't lift or angle stumped

Discussion in 'Western Plows Discussion' started by snord, Oct 26, 2009.

  1. snord

    snord Junior Member
    Messages: 13

    I've read through a ton of forums in Western and Fisher part of this site and not finding a solution to my specific problem and thought I'd throw it out to some of the veterans here.

    I bought the plow and it worked fine except it wouldn't lower once raised. Lift, angle, scoop, vee all fine. I decided to rebuild (i.e. reseal) the power pack and thoroughly cleaned every part of it with brake cleaner and compressed air. Replaced every o-ring. Also rebuilt the angle rams. Set all the relief valves to factory standards so should be close.

    Filled reservoir with fluid and plugged it in and the motor runs but only got a very puny response when did the scoop function where the right wing moved forward a couple inches and would move back and that's it. No raise, no angle.

    Discovered the previous owner had a 40 cartridge where a 43 cartridge was supposed to be in the s3 spot so replaced that. Checked all the coils for magnetism at different functions and all were magnetized that should be at the right times.

    Now have no function at all -- motor runs (not continuously) but nothing moves. Everything on the truck side including controller and wiring are fine because I can operate another unimount mvp plow with no problems. Wiring on plow side should be fine, especially since this plow worked except for lowering before I went through it.

    Thinking it is not building pressure for some reason. Don't have a pressure gauge to test the theory right now, but did notice a lot of air in the fluid when I removed the 40 cartrige. So, I pulled the reservoir cover and checked the o-ring that secures the pump to the housing and it looked fine. The pickup screen is new and checked it's o-ring, too, though I thought it could have fit a little tighter, but not sure if that is critical to build pressure.

    I may have some air in the cylinders and according to another post, I shouldn't have done the raise function when I first hooked it up after going through it, but I did so be it. I wouldn't think that would cause it to not work at all, but just make it work pitifully until I get all the air out.

    I'd take it to a dealer if they weren't all a week or so out. Any suggestions???
  2. snord

    snord Junior Member
    Messages: 13

    Is it possible to put the pump in the reservoir back together wrong? Should I drain the fluid and take the reservoir cover off and do a quick test to see if the pump spins? What are the possible sources of all the air bubbles and presumably lack of pressure?

    If you love a good mystery, someone take a shot at this one...don't be shy.
  3. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    did you put the oring back on the pump base? hold onto the hoses and have someone run the wings. you should be able to tell if there is pressure in the lines.
  4. snord

    snord Junior Member
    Messages: 13

    Yes, I rechecked the pump o-ring and bolted the pump back on. I think I might have forgotten to replace the o-ring on the part of intake assembly (with the screen) but not sure if that matters. I'll have to wait to have somebody run the controller while I push on the wings as I've mounted my other plow and hoping for some big snow out here in Colorado tonight/tomorrow. I'm basing the thought that the pressure is low mainly on the multitude of bubbles in the fluid.
  5. snord

    snord Junior Member
    Messages: 13

    problem fixed

    All right, not to toot my own stupid horn, but I believe the problem was the intake screen was turned up so that it was partially above the fluid level and was sucking air, so turned it down. I also replaced the electric motor at the same time as I did that, but don't think that was the problem, though by the look of the motor it was due to get replaced and there is a chance I didn't get it all put back together quite right.