1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Unimount controler? Plow will do nothing?

Discussion in 'Western Plows Discussion' started by bkabina, Oct 29, 2011.

  1. bkabina

    bkabina Junior Member
    from pa
    Messages: 14

    I've joined awhile ago and mostly just lurk around and read, but never post. I have tried searching for my problem and come up with nothing.

    I installed an older unimnount on my truck over summer , and everything worked fine. I unhooked the plow in my garage a few months ago and left it until today. I went out this morning to hook to it to start plowing and it does nothing.

    The power light comes on when I switch on the joystick and when I try to lift the plow or anything else the light goes out and nothing happens. I don't hear any clicking or pump noise or anything else for that matter.
    The plow lights work and the contoler is getting power put the plow will not respond. Can anyone help, I'm pretty new to troubleshooting a plow problem. Thanks
    Last edited: Oct 29, 2011
  2. bkabina

    bkabina Junior Member
    from pa
    Messages: 14

    Just tried a jumper across the solenoid posts under the hood and the pump ran. Would that mean the solenoid is bad? Or is there something else to check?
  3. Tinman01

    Tinman01 Junior Member
    from 18051
    Messages: 1

    Plow won't work

    I had a similar problem on my unimount and discovered that my motor lost it's ground. I attached one end of a wire to the ground cable at the back of the plow motor and attached the other end to one of the hexhead bolts at the top of the plow motor. Plow worked ever since
  4. Tony350

    Tony350 Senior Member
    Messages: 546

    If you jumped the solenoid and it ran then I would say it is the solenoid.
  5. cet

    cet PlowSite Fanatic
    Messages: 7,257

    If the light goes out when you try to use it I bet you have a bad ground. Clean the power cables that you join together at the front of the truck and check to make sure your battery connections are tight.
  6. mishnick

    mishnick 2000 Club Member
    Messages: 2,353

    I would check your ignition feed to the joystick. That is the red wire that splits off the cable just before the controller. Sounds like you could have tapped into something that isn't a reliable 12V source. Put a voltmeter or test light on it and then try lifting, see that the voltage doesn't drop off when you try to use the plow.

    I am not clear on how you jumped the solenoid. Did you just short out the two big lugs or jump the little ones? If you jumped the big lugs that only verified your motor & power wiring is OK, it saying nothing about the solenoid. If your controller is turning off it's not a solenoid problem. To verify the solenoid remove the two small wires and then ground one solenoid small pin and put 12V + to the other, if it clicks and the motor turns then the solenoid is fine. But be carefull because the plow will angle when the pump activates with no controller input, don't get crushed between the plow & truck! Check the small ground wire at the battery too, should be a black wire with an org tracer splitting off from the main motor ground cable near the battery.
    Last edited: Oct 30, 2011
  7. bkabina

    bkabina Junior Member
    from pa
    Messages: 14

    Thanks everyone. While waiting for replies I done some systematic testing and have figured out that it was the ignition wire. Turns out mishnick would be correct.

    Once again, Thank You all for your responses.
  8. renegade660

    renegade660 Junior Member
    Messages: 1

    I just had the same thing.Older uni mount, 02 F-250 SD..worked fine last yr...Now nothing...when I push stick left or right the controller makes a buzzing...nothing up or down...I just put in a new relay..same problem...checked wiring, grounds,all good...tried a diffrent controller same problem....I notice the light dims on controller when using it....(battery is new ) Any help would be greatly appreciated...We just got 8in. snow and I lost a bunch dough ...NOT HAPPY
  9. Glenn Lawn Care

    Glenn Lawn Care Senior Member
    Messages: 552

    Maybe you have a bad controller... Hopefully not because they care not cheap!