truck heat

Bill c

PlowSite.com Veteran
Location
ny
I have a 85 pickup that will not build heat.It has a new rad,heater core,195 thermostat.The hottest the water gauge reads is 180 degrees.If anybody has any advice it would be greatly appreciated.
 

Fierospeeder

Junior Member
I would look for the heater hoses that run to the heater core and just touch them quickly. Just to get an idea if it is hot, its those two small tubes running towards the cabin.

Is the radiator fan spinning? Its about 30 degrees out here, and that wouldn't really help by cooling the engine.
I see people put cardboard in front of their vehicle to help it warm up.

Your thermostat can be bad, it can be stuck open, letting coolant to flow into the radiator. Ive heard people have that problem people even if they bought a new one. You can test it by putting it in a used pot and heat the water with a thermostat. If it reaches 195º, you should see it open up.
 

Chuck Smith

2000 Club Member
Location
NJ
I run a 180° thermostat in my truck, and never have trouble with heat. It's an 80 GMC with a 350.

~Chuck
 
OP
B

Bill c

PlowSite.com Veteran
Location
ny
Hi guys I changed the thermostat twice each time a different brand.The antifreeze is mixed 50/50 with a protection rating of 37 below.I noticed that the fan is spinning all the time,could this possible be my problem?The autoparts store clerk suggested that the fan clutch my be bad.Does anybody know when the fan should engage and disengage.Thanks for all of the input.
 

Fierospeeder

Junior Member
my manual states


"the fluid drive fan clutch is disengaged when the engine is cold, or at high engine speeds, when the silicone fluid inside the clutch is contained in the reservoir section by centrifugal action.

remove fan shroud

loosen the alternator mounting and adjustment bolts, push alternator in towards the engine and loosen the drivebelt.
slip the drivebelt of the water pump pulley

unbolt the fan assembly and detach it from the water pump

fan clutch can be unbolted from the fan blade assembly for replacement
 

Power mad

Member
Location
Oregon
What do you mean by not building heat? Do you have no heat from the vents? Or is the gage reading 180? And as far as the fan turning all the time, so what. The fan draws air through the radiator cooling the mix until the thermostat opens and alows the coolant to flow and it starts the cycle over again. I have Auto meter gages and at 180 I have plenty of heat from the vents. If the small 5/8" Heater hose is hot but the big 3/4" hose is cold then there is a restriction in the heater core. Or is it the other way around? either way.....
 
OP
B

Bill c

PlowSite.com Veteran
Location
ny
Thanks for the info guys,we found the problem which was that the heater core was not tight against the temperature door and the air from the blower motor was going around the core and not threw it.
 

Top Forums

Similar threads

Similar threads

Top