1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Tower not energizing

Discussion in 'Boss Plows Discussion' started by jerrywane, Jan 15, 2012.

  1. jerrywane

    jerrywane Senior Member
    Messages: 134

    BOSS 8.5 ST8 BLADE....... i havent been here in a while and hope all is fine . I went to hook up my plow today to sell it,truck and brand new snowex 1875 (i had a wreak in April and cannot do the stearing) and the tower will not come up. i read alot about it through past post and still cannot figure it out.I got it to engauge one time for a split second,so i checked the cylonied and sure nuff,it had a broken post on it. I had another and carefully installed it but didnt fix the tower problem. The blade will go L& R and tries to go up,but when i try to use the controller to make it go down nothing at all happens......i dint get to use this plow yet as it was early spring when i bought it used. It worked fine then,and when i parked it. Some one before me butchered the wiring and used two sets of 7 pin round connecters instead of the 13 pin. It worked though,and someone (B.B. i think) said that if the blade was too far out in front that it would not let the SH engage any help would make my day! Thank you ussmileyflag
  2. RepoMan1968

    RepoMan1968 Senior Member
    Messages: 439

    Butchered ? Theres one lead .
  3. to_buy

    to_buy Senior Member
    Messages: 278

    Pull it all out and start from scratch.
  4. jerrywane

    jerrywane Senior Member
    Messages: 134

  5. jerrywane

    jerrywane Senior Member
    Messages: 134

    was working fine when first installed i need to sell it as i cannot plow because of an accident and the shoulder is shott
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If the SH won't work and you you can't push the tower up by hand with the controller in float then I'd say the problem is you're not getting power to the lower/float coil from the controller on the orange wire. If there's no power at the lower/float coil the SH won't work (since it's powered by that wire) and without float working either you can't push the tower up by hand. Time to get the test light out and as bad as the harness is butchered I won't be surprised the orange wire is dead at the coil as mentioned.
  7. jerrywane

    jerrywane Senior Member
    Messages: 134

    like pushing on a wall

    I think and hope that it is just to tight as i am unable to push the tower more than an inch...i have pulled it up tight thinking that it would help the SH work,but i think it is too tight. I have read in here that the blade could be too low, i will try it later and thank you