Snow Plowing Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
So I got the 89 silverardo with no solid front axel... now what?

Front what I hear the front end {something in the front} makes a light kinda ding when i am in 4 wheel drive... anyone out there have any ideas what it might be?

the outer cv joints seem to be ok.... so i am leaving the front shafts in right now...

someone said it might be the torstion bar {i can not spell it}

now what?

Zamaro
 

·
PlowSite.com Veteran
Joined
·
534 Posts
the torsion bars themselves have a rubber "mount" toward the rear. similar to a motor mount. i have had a knocking sound come from these when they fail.usually when turning hard or when the torsion bar is "worked" aggressivley

inexpensive repair
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
so the rubber mount?

I need to be on the ground next to it when someone drives it so i can see whats happening...

do i need to take apart the front end to change them or can i just "undo a couple bolts and put a new mount in?"

thanks

zamaro
 

·
Registered
Joined
·
77 Posts
I had the same thing happen to my 97 K2500HD. When in 4wd it would make a cluck from rev to fwd. and the other way around. It was the hub on the driver side. (its the thing where the wheel bolts to the a-frames and the axel goes in the center of it) Its a common promblem. I see yours is a 89 so no abs but if you did have abs the abs would come on at low speed stop for no reason
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top