1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

ST Series plow dead

Discussion in 'Sno-Way Discussion' started by Bronco#3, Feb 26, 2008.

  1. Bronco#3

    Bronco#3 Junior Member
    from NY
    Messages: 4

    Hello all,
    Need help with a ST series plow, wired controller, monarch pump.
    Plow was working fine last week. Went to move it 3 days ago, and
    it was dead. Lights on controller work (red for DP and green on/off)
    Power to battery side of MS. No power to pump. If I jump the MS
    the pump spins. Otherwise, no clicking of any relays. Fluid in pump
    reservoir. 10 amp fuse checked and ok. Voltage at + terminal of MS
    was 14.25. Went to dealer for new MS but he didn't have the snoway
    one in stock. Gave me a Western model#1306315. Looks the same.
    Still didn't work. Is there a way to check the receiver module to see
    if it is getting the signal from the hand held controller?
    Anything else that I am overlooking? Can't bring it to dealer as plow
    is in the Down position.
  2. nbenallo33

    nbenallo33 Senior Member
    Messages: 826

    the western relay should be the same one... but if that wasnt the problem make sure you use a test light on the fuses i have seen the fuses blow where you can't see the break with your eye... it could be the brain box check all connections on the ground and power... if the plow is down jack it up with a flooor jack and put the cylinder clamp on and you should be able to transport it
  3. Pearcelawn

    Pearcelawn Senior Member
    Messages: 368

    You say you have the wired controller. Take the controller out of the truck and hook it directly to the plow. At least you will be eliminating a short there.

    Good luck!!
  4. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    You have a multi meter GREAT! you can check for 12v at the MS. ask the unit to raise and see if you have power to the MS. the controls works on 5 volts if the unit lights solid than you have power and a ground. the lights should flash when you give a command. if they don't flash and you have a wired unit, it's probably a fried control. If it flashes then check to see if you are getting signal to the MS when you ask it to raise. If it flashes and the MS gets no signal then the Reserver might be shot.

    Your unit only has one fuse? the early units had 1 the later units had 2.

    You should have gotten a travel lock with your plow. You can jack the plow up, install the travel lock and take it to the dealer.

    If you want to get tricky you can throw 12 volt to the C+F coils, jump the motor solenoid, disconnect the 12v to the coils while the motors running then stop the motor, do it right the plow will raise and stay up. down power coils while the motors running is the key. I recommend the travel lock method:nod:
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    I had a customer buy a new receiver. Said he had checked the fuse it was fine. replaced the receiver still didn't work, brought it to me, I checked the fuses with the MM, replaced "blown" 10 amp fuse interduced the transmitter and it unit worked fine. Shame the customer threw the probably good wireless recevier away.
  6. Bronco#3

    Bronco#3 Junior Member
    from NY
    Messages: 4

    Thanks for the responses.
    I have 2 controllers and I did connect them directly to the
    control module(brain box). I did check the fuse and I get power going in
    and out. I had read previous posts of non-working plows and most stated that they heard clicking of the relays. I don't hear anything at all. It seems that the power is getting to that control module-but nothing after it.
    Thanks for the tip on jacking the plow. I at least have that option of going to
    the dealer with it.
  7. Bronco#3

    Bronco#3 Junior Member
    from NY
    Messages: 4

    To eliminate one possible problem, I just changed the 10amp fuse. Still
    no go. The green on/off light flashes when I press any of the other buttons.
    Is this normal?
  8. nbenallo33

    nbenallo33 Senior Member
    Messages: 826

    must be a bad brain
  9. Rich Forssberg

    Rich Forssberg Junior Member
    Messages: 6

    ST dead

    Have you checked the circuit breaker under the hood?
  10. Bronco#3

    Bronco#3 Junior Member
    from NY
    Messages: 4

    Thanks All for your help.
    I went to the dealer and he let me borrow a "tester" brain box to see
    if that was the problem. Sure enough the "tester" worked. Back to the
    dealer to return the "tester" and bought a new brain box and all is
    working again.