1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Speedcaster 2, no lights on control box.

Discussion in 'Fisher Engineering Discussion' started by SebagoLakeRanch, Jan 7, 2014.

  1. SebagoLakeRanch

    SebagoLakeRanch Junior Member
    from 04038
    Messages: 9

    We've had a Speedcaster 2 for many years, but haven't used it in a few. I tried hooking it up yesterday but can't get it to work. First of all on the big connecter, the small plug on the truck side was full of blue corrosion. I think I got it cleaned pretty good and then matched up the plugs.
    I tried turning the switch on in the cab for the controller box and got nothing, no light whatsoever. I tested the two red wires coming into the box and they both have power.

  2. DoplerG85

    DoplerG85 Junior Member
    Messages: 10

    I have a Speedcaster and had a similar issue. No lights at all on the controller. I had to clean out the plug on the back of the truck really good. It had the blue crud in it like rusting copper has. I used a combination of WD40 and Battery Terminal cleaner. I went through several Q-Tips to clean each hole. Eventually it worked. I didn't have a plug cover for it, so I went to my Fisher Dealer and got one. Hopefully that keeps the junk out. I also filled it with the dielectric grease you use for headlight bulbs and connectors. Buy a tube and get into the habit of filling the holes every time you remove it.