1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Snoway downpressure pump not running

Discussion in 'Truck & Equipment Repair' started by hadley321, Dec 28, 2012.

  1. hadley321

    hadley321 Junior Member
    from Hadley
    Messages: 2

    This is my first post and I tried to find what I was looking for in a search but I couldn't find it. Any help would be greatly appreciated. I'm new to Snoway plows so I'm quite lost. I looked at the PDF's to try and troubleshoot but it just says to see dealer.

    First I have an older 24d model with a Fenner pump and just used it for the first time yesterday, it works great except for the down pressure not working. It goes up/down/left/right flawlessly.

    When I raise the plow and lower it with the DP switch on it lowers very quickly, much more so than in float. But the pump doesn't come on to apply any pressure to the ram. I took off the wire for the DP at the valve and it didn't go down with the switch activated but would when I touched the wire to the valve, so the valve is working correctly?

    How does the pump get activated? What would cause it not to run in DP mode?

    This is a great forum by the way.
  2. Plowtoy

    Plowtoy Senior Member
    Messages: 929

    Welcome to plowsite!! You may want to look up basher on here for your snoway questions. They are snoway experts and most likely will lead you in the right direction. If you cant find him, his email is snowtech@basherandson.com Good luck, Dave
  3. hadley321

    hadley321 Junior Member
    from Hadley
    Messages: 2

    I figured it out, it was a loose wire at the truckside connector. It wasn't corroded it just came loose. I fixed it and it works great now.
  4. tj16064

    tj16064 Junior Member
    from ohio
    Messages: 1


    i have a sno way 26 with the old type wireless remote and dp when i hooked up the plow the motor would not shut off now you can hear the coils, but the motors not running. anybody with help thanks
  5. Rick547

    Rick547 Senior Member
    from Indiana
    Messages: 537

    Snoway had a problem with the older wireless controllers unit. Had to replace mine a couple of years ago. I hope that is not your problem as it is not cheap to replace the unit.

    Try reseting the unit. Basher has posted the procedure on the site. If you can not find it I will see if I can but I will have to go hunt for it.
    Last edited: Dec 29, 2012
  6. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Change the 12 volt motor solenoid.