1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Smath hitch doesn't work

Discussion in 'Boss Plows Discussion' started by mypolaris1, Dec 29, 2013.

  1. mypolaris1

    mypolaris1 Member
    Messages: 59

    Ive got good connections inside and magnitism @ the solinoids. I even hear the motor "click" when I hit the toggle switch. Everything works on the plow fine except for the smartitch. I tried a new switch, didn't help. Ideas?
  2. trevier

    trevier Senior Member
    Messages: 148

    this happened to me. You have to hold the controller down until it's red, it worked for me.
  3. jhenderson9196

    jhenderson9196 Senior Member
    Messages: 615

    Plow in float? Double check the ground at the power cable. Both the quick connect and the battery. 99% of Smart Hitch troubles are at the quick connect cables.