• PlowSite Homepage Upgrade

    Hello again PlowSite community,

    I wanted to post a quick note to let you know that the homepage of PlowSite will experience a major upgrade next week. We’re always looking for ways to improve our users’ experience on the site, and felt that this upgrade was needed and long overdue.

    With this upgrade, you’ll now see the top trending posts as soon as you visit PlowSite, and these will be updated throughout the day. You can also easily access videos and photos. As always, we encourage you to include videos and photos in your own posts to share with your fellow PlowSite users.

    Be assured that all of the forums, content and data that you’ve been accustomed to will remain intact, as will all current site features. You’ll also be able to easily access the full list of forums directly from our new homepage.

    We’re excited to bring you this change, and look forward to hearing your feedback.

    Thanks, PlowSite Team

Service 4WD

watatrp

Senior Member
Location
South Bend, IN
I have a 2001 Chevy 4X4. The "Service 4WD" light comes on ocassionally. Usually goes off the next time I stop and then start up again. When the light is on, I can't switch from 2WD to 4WD. Would be a problem if it happens when I'm trying to plow. The dealer says that it is most likely a faulty sensor. He says to bring it in when the light is on. My problem, it happens maybe once a week and never when I'm near the dealership or when it's open. How do I get this fixed? Anyone else had this problem?
 
OP
watatrp

watatrp

Senior Member
Location
South Bend, IN
Unfortunately that is not the case. Had the truck in for periodic servicing and they tried to get the code and found that the code is not one that is stored. On the way home the light came on so I turned around and went back with the truck running and the hooked it up and were able to get the code then. Ended up being a faulty sensor and covered under warranty. I guess it's a pretty common failure.
 
Top