1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Salt Dogg Electrical Problem

Discussion in 'Truck & Equipment Repair' started by DSLL, Dec 4, 2009.

  1. DSLL

    DSLL Senior Member
    Messages: 136

    Went to hook up our newly acquired salt dogg poly hopper, 1.5 yard, and the spinner didn't work. The auger and vibrator worked as they should. However, the spinner wasn't moving at all. Brand new controller and wiring, this is the first time we went to hook it up and test it. Salter is not new.

    If power is put right to the spinner motor from a jump box the spinner spins freely. Also there is power at the wiring side of the harness for the spinner, checked with a voltmeter, 12.5ish volts.

    Hooked wire leads up from the auger connector to the spinner and the spinner did work, able to control the speed too with the auger control.

    Also replaced the pieces in the female side (salter side) of the wiring connector at the spinner because they were being pushed back in and not making good contact or so we thought. But, when we bypassed this connector on the salter and hooked the spinner motor to the wiring harness connector it still did not work.

    Wires to the spinner motor were pretty corroded but we did clean them pretty well. Motor works when hooked directly to jump box.

    So what the heck is going on with this Dogg? Thanks in advance, Marc
  2. WeDoSnowplowing

    WeDoSnowplowing Senior Member
    Messages: 160

    Last edited: Dec 6, 2009
  3. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Corrosion is probably worse than you though and has traveled up the mires causing a break in the wires. need to check each wire for a break and low voltage through it.
  4. timberseal

    timberseal Senior Member
    from 46385
    Messages: 247

    Check for power at the plug/controller so you can narrow it down between a bad controller or harness. I had a brand new unit delivered this fall and the controller was bad - the auger side wouldn't work. They shipped me a new controller and all worked perfectly.

    Its an outstanding unit by the way... we've ran about a ton of salt through it and it just works awesome.
  5. DSLL

    DSLL Senior Member
    Messages: 136

    Thanks for advice guys. Checked the harness for continuity and it check out. Sent the controller back and have another one on the way. This should solve the problem, I hope.
  6. M&S Property

    M&S Property Senior Member
    Messages: 117

    We went through three controllers on our Under tailgate and then the dealer finally figured out that there was a pinched wire (from the factory) in the harness and it was frying controllers as soon as you tried to turn on the auger. Moral of the story is check the harness again and be sure before you plug in the new controller.