1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Problem with my SmartHitch

Discussion in 'Boss Plows Discussion' started by SpruceLandscape, Feb 3, 2007.

  1. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    Hey guys, weird thing happened tonight. I went to hook my plow on the truck and when I activated the switch on the side of the upright, it wouldn't lift the plow. The pump is working because you can hear it, although it doesn't sound quite right. However, when I push the switch down it will activate the hydraulic and pull the uprights down. Weird... So I got in front of the plow and manually pushed the light assembly up so that it engaged the truck, didn't feel any resistance other than the weight of the pump assembly. Once it engaged I was curious to see if the switch would work then and I had the same result. Went inside the truck and my controller had no problem moving the plow up and down, side to side. What do you think? It is pretty cold here, about 5 or 6 degrees F, think that has anything to do with it?
  2. stroker79

    stroker79 2000 Club Member
    Messages: 2,802

    Im sorry for asking the obvious but you KNOW it was in float right? Im not trying to insult you but i know that i have done that before as well. Or maybe the switch is bad? or the wiring behind it?
  3. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    Yes, I went back and tried it a few times making sure that it went into float before trying the switch. Like I said, the pump was making noise when I flipped the switch up, just no hydraulic action. But, when I flipped the switch down, it does try to pull the light/pump assembly down... Bad switch maybe? I'm at work today and will pull it inside to let it thaw before I take the cover off. Wonder if some salt got in there and is shorting it possibly.
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Not too uncommon for the smart hitch switch's to fail but before you buy a new one pull the cover off and check the wiring terminal's, as sometime's they'll fall off from all the vibration.If you do end up replacing the switch their easy to change and not very expencive either.
  5. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    well, I did get a chance to pull my truck in at work today, but didn't have much of a chance to pull the cover off of the pump to inspect it though. However... after blasting it off with some hot water mostly just to rinse off the salt, and after I let the truck sit inside for about an hour, the switch worked just fine. only thing that happened between yesterday and today was the drive in which is about 15 miles on the freeway.
  6. wild bill

    wild bill PlowSite.com Addict
    Messages: 1,239

    smart hitch

    check all the grounds on the coils under the black cover expecially the smart hitch valve,clean between the valve and coil; and run extra grounds if it is an earler unit smart hitch one
  7. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    It is a smarthitch II, but I was just informed from the dealer that seeing as I bought this in august of 05, that is right around the same time they were doing a change over from the old switch to a sealed switch and that it is entirely possible that I have the older style switch, which apparently was changed because of the same problem I am having... that is water getting into the switch and freezing, therefore limiting its operation.
  8. NoFearDeere

    NoFearDeere PlowSite.com Addict
    Messages: 1,724

    I had a little problem last time I hooked my plow up. The switch and hydraulics were working but it wasnt lifting the tower up. So I pushed up on the tower a few times and then it worked. I think it was just frozen is all. Could be something that simple. Otherwise, check all your connections on the plow and make sure your plugs, on both the truck and plow, are clean and put some di-electric grease on them. :) Just what I had come to mind...:rolleyes: Good Luck
  9. jbwerling

    jbwerling Junior Member
    Messages: 27

    I also had the same thing happen. Kind of a mystery to me also. Most of the time if I had that happen, I would check to make sure my 2 plugs were pluged in correct and that my truck is making good contact with the plow. The plow then would lift right on. I think on my plow alot of it was just making good ground.:confused:
  10. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    Well, went to the dealer and found out that the original switch was of the non-sealed variety. Slight amount of corrosion inside of it looks to be the culprit, so had the switch replaced with a newer sealed unit and was covered under warranty.