1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Problem with my Boss 7.5ft - please help !

Discussion in 'Boss Plows Discussion' started by ghavens, Dec 21, 2008.

  1. ghavens

    ghavens Junior Member
    Messages: 11

    I have been pulling my hair out, almost bald now.

    I have a Boss RT3 Straight Blade system and it is mounted to a 1996 Chevy Suburban.
    I had taken the plow off a 99 Dodge Ram and installed to the Chevy about a month ago.

    All was working ok, until Friday when it started acting up during our heavy snow in MI. I got stuck in deep snow, pulled off the driveway. After getting unstuck it was plowing ok, then started acting up where the plow worked, then it didn't, then it worked again.

    After driving home I put the blade down in my driveway, and that was all she wrote, blade will not go up or down. The lights on the control are very dim. I did get the control to get the plow to bump a few times, but now it is up a couple of inches, and I can not even detach from the Surburban, nothing. I have checked the connections and cleaned up all connectors and applied Dielectric Grease to all connections. Ground it directly to the battery. Also, the headlights stopped working, they were only working on low beams previously after hooking the system up, but on Friday the running lights come on, but if switch all the way to headlight, I get a clicking sound.

    Anything to check specifically would be a great help. I do not have a spare hand control to try, so I do not know if this could be the problem.

    We just keep getting hit with snow and blowing snow and I really need to get this working - all help is greatly appreciated.
  2. peterk800xc

    peterk800xc Senior Member
    Messages: 188

    The obvious?

    Sorry to hear you got problems but me to.Mine wont go into 4 wheel drive and its a BN 08 Silverado! ON your problem, did you make sure that the battery is good? Also is the alternator charging what it should. Reason I ask this as my 04 Chev did the exact same thing and it was the battery. Good Luck.ussmileyflag
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Time to go after it with a test light and continuity tester.

    Check the brown ground wire connections at the relay pack for good ground.
    Check the black/red wire for full battery voltage.
    Check the relay sockets for corrosion.
    Swap a couple relays around.
    Check right at the controller plug for 12V on the black wire as well as for a good ground on the brown wire.
  4. ghavens

    ghavens Junior Member
    Messages: 11

    Battery and Alternator both check out good

    I will try checking the wiring connections at the relay pack first thing in the morning.

    Thanks for some additional areas to check and the specifics !
  5. aeronutt

    aeronutt Senior Member
    Messages: 262

    I had to get out the brake cleaner and some Q-Tips to de-funk the electrical connections where the dielectric grease had caught dirt and hardened. It couldn't hurt to try this on yours and then re-grease it all. Also, my main power plug didn't have a very firm connection so I slipped a tiny screwdriver into the split-pegs to spread them out and stiffen up the connection. It made a real difference in getting good, positive connections.
  6. ghavens

    ghavens Junior Member
    Messages: 11

    After spending yet another day checking, and cleaning, still no luck.

    I put on a new solenoid
    rechecked all ground spots I could think of. Installed new connection at the battery, pump motor is cood connection, but I removed, wire brushed, even though clean and reinstalled.

    Brown wire at battery ground, at relays and at controller connector all show good ground.
    I have 14.4 Volts at the solenoid connector to battery, 14.4 Volts in the relay packs where indicated for ignition wire and red/black wire, and black wire to controller. Also 14.4 Volts at the controller connector.

    All I get is a very very weak light on the handheld controller, but it does not do anything.
    If I jump the solenoid, the pump will kick in, so pump motor is ok.

    I wish I had another controller to try to see if that is the problem. I just don't want to pay $300+ if this is not the problem.

    I have also cleaned all connections on both sides of the 13 pin connector, Brake clean and Q-Tips all connections are good. I even split the pegs on the positive and ground main wires at the connector to insure good connections. Still no luck.

    Anything else anybody could think of checking?????????????
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Disconnect the connector at the controller, take a jumper wire and jump the red/black and the black wires together with the ignition key on, does the blade angle?
  8. aeronutt

    aeronutt Senior Member
    Messages: 262

    The fast way to try a new controller without spending $300 is to ask another plow driver with a BOSS to let you borrow his for 5 minutes. Or you could ask your local dealer to let you try one in their parking lot. For transport to the dealer, you could jumper pin 1 to pin 3 in the 9-pin controller plug (black to white) to activate the plow up function. Pin 1 to pin 2 (black to orange) lowers it.

    Good luck!

    EDIT: I just noticed that you put on a new main solenoid, but didn't say you swapped relays around. Try shifting them all one spot over and see if anything changes.
    Last edited: Dec 22, 2008
  9. ghavens

    ghavens Junior Member
    Messages: 11

    I just tried jumping the controller plug, with no luck. I think I may need to call in help. I did try swapping relays again with no luck either. I must still be missing something, and I can't get the blade up to transport.
    I did try jumping the solenoid again just to make sure the pump motor runs, and it does, but for some reason, I don't seem to be getting the power to the solenoid to engage the motor?
  10. ghavens

    ghavens Junior Member
    Messages: 11

    OK, I had one of my friends come over and help look at the situation. After looking we decided that power was not getting to the black/white wire going from the controller to the solenoid to tell the solenoid to send power to the pump motor. When we applied power, the controller worked, but without power, no go.
    We went to a Boss Dealer to since I didn't know anyone else near me with a Boss Plow to try a new controller, and what do you know, everything works with a good controller, unfortunetly the dealer wants $350 for a controller and had just sold his last one.

    I checked Ebay, and found a new straight blade controller for $250 with free shipping from Ken's Auto Sales. Actually I had previously bought my truck mount for my plow from Mike there as well. He is overnighting the controller and only charging actual cost for the overnight shipping.

    I would recommend Mike at Kens Auto for anybody in need of Boss Plow parts, he is in Holyoke, MA. He can be reached at 1-888-281-8507 and www.KENSAUTOSALES.com.

    Most of the Boss Dealers here in Michigan around the thumb area all charge retail + for their parts.

    Thanks to all that helped, even though I spend two days in the garage that I didn't have to, at least I have a lot of much better connections now!
  11. ghavens

    ghavens Junior Member
    Messages: 11

    Update, I was able to solder the bad spot on the controller circuit board to make the connection, and now have a working plow and a new controller on the way, but at least I will have a backup controller.
  12. SpruceLandscape

    SpruceLandscape Senior Member
    Messages: 248

    Good to know that everything worked out OK. Its never a bad idea to have a backup of EVERYTHING when it comes to your plow, just in casepayup