Pro Plus goes right when up or left button pushed!

Discussion in 'Western Plows Discussion' started by Section88co, Feb 1, 2011.

  1. Section88co

    Section88co Junior Member
    from Denver
    Messages: 6

    When I hooked my plow up last night and tried to raise it it turned right when I hit the up button then I tried to turn it left and it went right as well. The motor runs and plow moves to the right fine when up left or right buttons are pushed. During our last storm it did this once and I hit the control a few times in different directions and it started working normally again, I thought it was a fluke and I could not duplicate the problem again. It worked fine last year and I have never heard of anything like this. I did put dielectric grease on the connectors and nothing changed. It worked normally the first storm of the year and the only thing I did to my truck this year is put in two new batteries but it worked fine after I did. This is a 3 wire ultramount. Any help appreciated! Thanks!
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,755

    It's not reliably shifting the S3 valve. Need to check the S3 coil for mag when it's acting up. Lack of mag means an issue somewhere on the light blue wire from the coil to the controller or a faulty controller. Also check the ground wire on the coil for a good connection. Cleaning the spade and crimping the wire terminal just a bit will resolve that.

    If does have mag when it won't angle left or raise, remove and clean (or replace) the S3 valve.
  3. LVHardscape

    LVHardscape Member
    Messages: 38

    for what its worth, coils are cheap, like 13-15 bucks at your local western dealer. good to keep around even if its not your particular problem.
  4. OP

    Section88co Junior Member
    from Denver
    Messages: 6

    Turns out it was one of the plugs (3 wire) that plug into the truck. Thanks
  5. x.system

    x.system Senior Member
    Messages: 368

    My unimount that I converted to a 3 plug will do that once in a while, usually when I first hook it up. I just get out and wiggle the connection and it works again.