Snow Plowing Forum banner
1 - 20 of 67 Posts

· Registered
Joined
·
2,316 Posts
Discussion Starter · #1 ·
having issue with truck and plow
Truck side c 5500 diesel
3 new batteries and alternator
Just redid grounds in battery and truck batter connections clean and hood
Brand new fisher xl xls
When I hook up plow and turn controller on it flashes when I hit a button truck goes haywire lights bling and flash and u hear a clicking comming from plow
We redid ground wire on plow and it worked well till next day loaded with salt and went to go out and same plow issue
I un hooked plow and salted for 6 hours truck ran fine salter snowex 9500 ran fine whole time
Any suggestions
Plow is brand new already found some wires twisted in pump fisher said they shouldn’t be
Gonna try new controlller but doubt that’s it
And might try new selonid
Really need truck for tomorrow storm
 

· Registered
Joined
·
14,949 Posts
What if you add jumper cables from ground straight to pump ground?

Where is the plow ground hooked up at anyway?
 
  • Like
Reactions: cwren2472

· Registered
Joined
·
2,316 Posts
Discussion Starter · #3 ·
Not sure mechanic does it all
I was gonna swap plows with my other truck see if it is plow side issue or truck side issues and then look tomorrow because I hate waiting on them to do work
 

· Registered
Joined
·
2,316 Posts
Discussion Starter · #7 ·
It’s an Eletric selonid pto and that was just replaced
Long story short bought truck sight unseen well pictures only from dealer and it had so many issues dealer had it for 8 weeks and fixed all but when I got it back dump didn’t work so local mechanic replaced the 3 way selonid
Dealer is 4 hours away and I would never do business with them agin although they put over $7000 into repairs after I bought the truck
Local mechanic said truck wasn’t ground well so that’s why he ran 3 new grounds on truck
 

· Registered
Joined
·
2,316 Posts
Discussion Starter · #14 ·
Picking up the new modular now and going to put it in I tested it with the one off my personal truck we put the new modular if I’m going to double check all the wires it’s got a brand new harness from the battery to the plow and it’s grounded on a brand new ground to the frame try controllers wasn’t that I will double check the harness itself off the truck it’s possible it’s bad but the truck came off with my personal truck last year and it never gave me
 

· Registered
Joined
·
17,483 Posts
Picking up the new modular now and going to put it in I tested it with the one off my personal truck we put the new modular if I'm going to double check all the wires it's got a brand new harness from the battery to the plow and it's grounded on a brand new ground to the frame try controllers wasn't that I will double check the harness itself off the truck it's possible it's bad but the truck came off with my personal truck last year and it never gave me
Que...?
 

· Registered
Joined
·
2,316 Posts
Discussion Starter · #17 ·
Final update alternator is fine we when everything except the plow so all my lights my Salter my vibrator my flashers nothing drops the second we hit the plow button the voltage or drop to nine and the amps spike mechanic guesses it’s the snowplow motor
The clicking was because of low voltage so now everything on the truck side is new it’s grounded perfect
Plow brand new But again every time we hit a controller the voltage drops so the whole entire system is now brand new and the truck checks out as well we changed plow modules The plow selonid And nothing when the truck is at 14 V the plow works if I go back-and-forth left and right up-and-down it draws and the plow will start to click the second I stop using the controller the alternator is right back to 14v again
I’m thinking possibly a higher amp alternator Or there is something wrong with the brand new plow
 

· Registered
Joined
·
2,316 Posts
Discussion Starter · #19 ·
Well new alternator didn’t solve it
It did fix one other truck that couldn’t keep up
Still an intermediate electrical issue
I hooked up plow to different truck and plow works
I’m lost I give up I was told whole truck side is new not sure why the selonid isn’t grounded
It’s gettibg 12v and not letting enough pass through I was told
The owner of the shop is back from vacation and they have it again
I’ll let u know what I find out
 

· Registered
Joined
·
295 Posts
It sounds like you have high resistance somewhere in the main wireing for the plow pump. If you take jumper cables and power the plow motor does it drop voltage? Things i would check are the pins at the grill, mabe even spread them. rwmove and clean all battery, plow, alternator connections with sand paper. Also test your battey it may be weak.
 
1 - 20 of 67 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top