1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow won't move.

Discussion in 'Fisher Engineering Discussion' started by kissfan007, Dec 11, 2010.

  1. kissfan007

    kissfan007 Junior Member
    Messages: 5

    I have a Fisher Minute Mount plow. Got it on the truck and hooked up, but it won't move. You can hear the pump going, in all three positions, and something is pulling on the battery pretty hard when you try to move it. It won't even move down on it's own, so I stood on it and got it down to the ground. I cleaned the filter out, and even tried a different controller but still no luck. Any suggestions would be greatly appreciated.
  2. rymac320

    rymac320 Junior Member
    from Boston
    Messages: 1

    same problem...older one tho that im trying to sell. topped off the fluid, going to try and bleed it maybe theres air in it.
    strange because it worked fine the day before.
  3. buddymanzpop

    buddymanzpop Senior Member
    Messages: 603

    Plow won't move

    I think the first thing is to check and make sure your ground is good to the 3 cartridge coils.
  4. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,288

    Did you open up the cover to see if all the wires to the solenoids are connected? You can set your plow up so that it will go down instead of up if someone tries to take it.
  5. kissfan007

    kissfan007 Junior Member
    Messages: 5

    We've been trying to check all the wires and whatnot, but haven't gotten terribly far yet. We checked the power at the battery which ended up being around 14VDC, but it was only at about 8VDC on the pump motor. Any ideas?