1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

plow won't move

Discussion in 'Fisher Engineering Discussion' started by SharpBlades, Oct 7, 2010.

  1. SharpBlades

    SharpBlades Senior Member
    Messages: 366

    Ok, so about a month ago I bought a 7.5' mm2 straight blade. It worked fine on the guys truck i bought it from.

    I finally go around to having the truck side put on. Everything new except the joystick controller... bring the truck into the shop to mount the plow and try it and there is not really any power for hydraulics, and the controller light doesn't turn on. I did get the controller light to come on for a few seconds, and the hydraulic pump turned on, but nothing moved. Now i can get the pump to turn on for a split second when i plug in the 2 pin connector, but nothing else... please help

  2. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,613

    check and clean all your gounds and battery terminals. Is your solenoid new? Pulled mine out of storage and the solenoid was bad...
  3. SharpBlades

    SharpBlades Senior Member
    Messages: 366

    yes, the solenoid is new... But there is a slight whining noise coming from it.
  4. SharpBlades

    SharpBlades Senior Member
    Messages: 366

    well I think it is a bad solenoid. I ran jumpers from the battery to the motor. And that works... But maybe a ground. Who knows... Would either problem cause the controler not to light up?
  5. buddymanzpop

    buddymanzpop Senior Member
    Messages: 603

    Check the fuse that the red wire from the control harness is tapped into on the fuse block, make sure it's not blown.