1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow wont go right/left

Discussion in 'Fisher Engineering Discussion' started by performanceplus, Aug 29, 2010.

  1. performanceplus

    performanceplus Senior Member
    Messages: 117

    I went to move my plow yesterday and when I picked it up I had no side to side movement. I tried to go left and it started to raise up real slow. I went to go right and it sounded like the cylinder was trying but couldn't move. I imagine it needs new cylinders but not sure. Any ideas/help? Thanks.
  2. quigleysiding

    quigleysiding PlowSite.com Addict
    Messages: 1,129

    Try kicking it with someone holding the control left or right. Last year mine did that all it needed was a little help to get loose again. It was fine all year.
  3. performanceplus

    performanceplus Senior Member
    Messages: 117

    Do you have a MM2? I will give that a try.
  4. quigleysiding

    quigleysiding PlowSite.com Addict
    Messages: 1,129

    My plow is a mm1. You said you could here the motor running so it might be just stuck.
  5. gtmustang00

    gtmustang00 Senior Member
    from Berlin
    Messages: 752

    My buddies plow was doing the same thing. It wasn't the stick it was one of the plugs had a few loose wires going into it on the plow side. Have a buddy wiggle the wiring while you have the stick angled.
  6. NHresident

    NHresident Senior Member
    Messages: 304

    try chkng the fluid
  7. bullettooth81

    bullettooth81 Senior Member
    Messages: 103

    I had the same thing happen to my Boss the first time I used it last year. It was just stuck from sitting over the summer. I got out and kicked it a few times, then pushed ito a pile and it started working. Worked perfect for the rest of the year.
  8. TeamBrain Damag

    TeamBrain Damag Junior Member
    from MA/NH
    Messages: 6

    check the wiring, I have used MM1 did the same thing, the previous owner changed the end plug, and one of the wires came loose.
  9. Grassman09

    Grassman09 2000 Club Member
    Messages: 2,808

    Check to make sure all the pins are in tact and not corroded. I always had the same issues the blade would do the opposite of what you pushed on the controller. I had to get out and wiggle the plug as they didn't make proper contact.
  10. buddymanzpop

    buddymanzpop Senior Member
    Messages: 603

    S2 cartridge could be stuck or not energized, check for magnetism at the coil when action is requested from the controller, if magnetism is present you will have to pull the cartridge and check that for movement, you'll need a helper to do this seeing how it's pretty impossible to activate the controller and check for function at the valve pump assembly at the same time.
  11. SnoPro Inc

    SnoPro Inc Senior Member
    Messages: 113

    Check hydro oil, maybe a bad solenoid?