1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow won't go down.

Discussion in 'Western Plows Discussion' started by premium lawns, Nov 3, 2011.

  1. premium lawns

    premium lawns Junior Member
    Messages: 11

    Just bought a western unimount v plow last week. I wired everything correctly(I believe). The scoop mode, v mode, angle left, angle right, and up all work, BUT THE DOWN doesn't work. When you press down on the hand held control pad you can here the motor run, but its not that loud its pretty quit. I don't know what the problem is. Could it be a solenoid or is the motor bad?

  2. premium lawns

    premium lawns Junior Member
    Messages: 11

    Just drove around for a little bit with the plow in float mode and it finally went down. i tested it out for awhile, went up, down, up down all angles etc. Then tried going down and it wouldn't, could it be an air pocket?
  3. cascae

    cascae Junior Member
    Messages: 3

    Had a similar issue a couple of years ago with my plow. Ended up just being a bad connection on the battery terminal, once I replaced that it worked perfect.
  4. premium lawns

    premium lawns Junior Member
    Messages: 11

    Thanks I will try that tonight.
  5. ygim

    ygim Member
    Messages: 81

    double check all connections
  6. mishnick

    mishnick 2000 Club Member
    Messages: 2,355

    If the motor spins when you press the down button you have more serious problems than a loose connection.. The only thing that should happen when you press down is that power is sent to one valve to allow fluid out of the lift ram. I don't know what kind of V plow you have so can't tell you which one... I suspect your hand held controller is pooched. Certainly not a solenoid cus the solenoid works for all other functions, same with the motor. The down function is the only one that doesn't need those two parts to work. And air is not the issue either, even with no fluid in the reservoir and all kinds of air in the system if the valves are working the plow would go down if it was in deed being held off the ground by hydraulics. Borrow and hand held controller from a friend and try it, that is most likely your problem.
  7. premium lawns

    premium lawns Junior Member
    Messages: 11

    We switched out one of the grounds on the plow side and it seems to work for now. If not we were thinking the controller also.

    thanks guys!
  8. mishnick

    mishnick 2000 Club Member
    Messages: 2,355

    So this must be one of the new MVP plus models with multiplex controls and the two cables at the grill right? If you switched something on the plow side it must have been connected wrong at the factory.
  9. premium lawns

    premium lawns Junior Member
    Messages: 11

    Its a unimount mvp. It worked all day today, I drove around town all day with it where ever I went. Tried up down at every stop light, had alot of people looking at me.
  10. birddseedd

    birddseedd PlowSite Veteran
    Messages: 3,516

    not a plow expert, but i do deal with electronics. a bad ground can cause electricity to travel in the wrong direction in the controler which is probably why you were getting weird results on the float position.

    glad youv got it goin.