1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow won't drop

Discussion in 'Western Plows Discussion' started by ParadiseLS, Jan 4, 2012.

  1. ParadiseLS

    ParadiseLS Junior Member
    Messages: 6

    Isarmatic Pump - plow won't drop

    I removed the manifold, motor, and pump and installed them into a new pump housing. The old one was leaking, taking in water, and making snowplowing really frustrating...In spite of the leaking and the water contamination with the old housing, and the consequent freezing I had to deal with, the plow moved perfectly and worked well.

    anyways, I put the new pump setup together, filled up with Blizzard Rapid Action Hydraulic Fluid (dealer said it would be as good as Western HP). Plow lifts, plow moves right to left, then I hit the switch to lower, and it will not go down.

    I removed the relief valve plug to drain out the lifting ram and drop the plow. I made sure the packing nut was properly tightened, checked that the wire to the S1 valve was not loose, stripped, corroded. Refilled the pump housing and tried again. Plow lifted, turned but wouldn't lower. I loosened the quill as far out as it goes. Will not lower

    I was going to do some troubleshooting this afternoon. Yesterday was way too cold, I didn't go out and bother with it. Well, when I went out today, the plow had dropped sometime in the past 24-36 hours. So I turn the truck on, lift it, angle it, drop it. BANG! *oops, the quill needs to be adjusted back to its normal setting* I adjust the quill, lift, drop, lift, drop. Everything goes great.

    I take the truck for a drive to run an errand, park in the parking lot and go to lower the plow. It drops a couple inches and then stops. Hit the lower switch again, it won't budge. Still lifts, moves left, moves right perfectly.

    Any ideas? I'm hoping that the brief time it was working might be clues to help me solve this problem quicker....
  2. Philbilly2

    Philbilly2 PlowSite Veteran
    Messages: 3,797

    You need to fix you S1 valve.

    Search the topic, there is hundreds of threads about the same problem.
  3. mishnick

    mishnick 2000 Club Member
    Messages: 2,353

    Put a test light across the S1 valve and see if it is getting power. If you leave the ignition on and hold the down button it will go into float and the S1 valve will stay activated so you can test it for power. If the test light lights up then take a screw driver and see if the coil is magnetized. If you get no light you have an electrical problem, possibly the grill plug or the controller. If there is power but no magnet then replace the coil. If you have power and magnatizm but the blade still doesn't drop pull the cartraige and see if it will click when you put power to the coil. It should be a clear audible click. The S1 and associated electrical has to be responsible for this problem.