1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow won't drop

Discussion in 'Blizzard Plows Discussion' started by Lazer Man, Jan 18, 2011.

  1. Lazer Man

    Lazer Man Senior Member
    from SW Pa.
    Messages: 140

    Ok here is the problem we have a 810 that started blowing the 20 amp fuse the driver relaced w/ a few but kept blowin fuses so he up the amps to a 25 amp then while using plow smelled smthing burning in the controler the plow wont work. After the driver getting back and I start looking at things, I replaced the reg controler from his and put mine on got plow to reg position started moving plow left and right no probs wings same ok. Then went to drop plow nothing. Switched to detatch mode worked fine lowered down, switched back to reg ops raised up fine no drop again. Any ideas what the prob is. Thanks for any and all help.

    Bob :confused:
  2. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    orange wire rubbed through/broken on truck side harness, grounding out somewhere.
  3. Lazer Man

    Lazer Man Senior Member
    from SW Pa.
    Messages: 140

    John I'm gonna look that and plow side over real well thanks. I appreciate the help.

    Bob :D :D
  4. Junior MO

    Junior MO Member
    Messages: 52

    I am having the same issue other than the blown fuse issue. Plow worked perfect until I get back to the shop for a few hours rest. Went to lift the plow and nothing. All other functions work other than dropping the plow. I can use the detach switch to lower, but nothing from my controls. I have tested all connections and I don't have a juice from my truckside connection to the controller. Could the controller be bad?
  5. beam

    beam Senior Member
    from pa
    Messages: 314

    bob check your s5 coil for power and if your still having issues text me or call
  6. damian

    damian Senior Member
    Messages: 330

    i would never put more than 15a fuse you could damage the controller or diode pack,find your short and check the s5.