Snow Plowing Forum banner
1 - 17 of 17 Posts

· Registered
Joined
·
132 Posts
Discussion Starter · #1 ·
I have a 2009 GMC 2500 hd. Im picking up my new 2018 GMC 2500 hd On Monday.
Old truck has a 8' HDX-2 with hand held control.Its not fleet flex that was converted to conventional 3 plug. I know some people will say go to 2 plug fleet but Im fine with the 3 plug.
mount=7169
head lamp=29400-5
3 port module=29070-1
New truck needs:
mount=7192
headlamp 69818
3 port module=29760-2
Both have HB-3/H11 head lights.
I was told by a local dealer said that I would only need to change push plates and a new headlight harness. Obviously the part numbers are different so I wanted to make sure that would be all I need to change it over. Is he right ?
Thank you for your help.
 

· Premium Member
Joined
·
17,303 Posts
I have a 2009 GMC 2500 hd. Im picking up my new 2018 GMC 2500 hd On Monday.
Old truck has a 8' HDX with hand held control.Its not fleet flex was converted to conventional 3 plug. I know some people will say go to 2 plug fleet but Im fine with the 3 plug.
mount=7169
head lamp=29400-5
3 port module=29070-1
New truck needs:
mount=7192
headlamp 69818
3 port module=29760-2
I was told by a local dealer said that I would only need to change push plates and a new headlight harness. Obviously the part numbers are different so I wanted to make sure that would be all I need to change it over. Is he right ?
Thank you for your help.
You are correct, the module is different also. You can add the soft start relay pack to your module though and not need to buy a new module. Part #76272
 

· Registered
Joined
·
132 Posts
Discussion Starter · #9 ·
I finally put it together over the weekend. Fun fun time putting the module in the fender. I hooked it up to check functions and everything worked, I didnt look too much at the truck lights but from what I remember they all worked. Hids didnt auto start, the sun was shining on the sensor the next day. I start the truck (no plow attached ) and the truck HIDS flickered for about 10 seconds and came on normal. I started the truck a few more times. Each team time they came on normal and faster to normal brightness. 3 or 4 starts and they come on normal. Batteries were disconnected over the weekend. Does it have to cycle to relearn the lights. When I got the parts and tools hi. I have hid and he side it didn't matter. I'm not able to hook up to the plow to test. I was hoping it's something simple. Any help will be greatly appreciated.
 

· Premium Member
Joined
·
17,303 Posts
I finally put it together over the weekend. Fun fun time putting the module in the fender. I hooked it up to check functions and everything worked, I didnt look too much at the truck lights but from what I remember they all worked. Hids didnt auto start, the sun was shining on the sensor the next day. I start the truck (no plow attached ) and the truck HIDS flickered for about 10 seconds and came on normal. I started the truck a few more times. Each team time they came on normal and faster to normal brightness. 3 or 4 starts and they come on normal. Batteries were disconnected over the weekend. Does it have to cycle to relearn the lights. When I got the parts and tools hi. I have hid and he side it didn't matter. I'm not able to hook up to the plow to test. I was hoping it's something simple. Any help will be greatly appreciated.
You need to remove the softstart relay pack if you have HIDs. In your original description you stated both vehicles were standard, not HID.
 

· Registered
Joined
·
18,088 Posts
I have a 2009 GMC 2500 hd. Im picking up my new 2018 GMC 2500 hd On Monday.

Both have HB-3/H11 head lights.
I finally put it together over the weekend. Fun fun time putting the module in the fender. I hooked it up to check functions and everything worked, I didnt look too much at the truck lights but from what I remember they all worked. Hids didnt auto start, the sun was shining on the sensor the next day. I start the truck (no plow attached ) and the truck HIDS flickered for about 10 seconds and came on normal. I started the truck a few more times. Each team time they came on normal and faster to normal brightness. 3 or 4 starts and they come on normal. Batteries were disconnected over the weekend. Does it have to cycle to relearn the lights. When I got the parts and tools hi. I have hid and he side it didn't matter. I'm not able to hook up to the plow to test. I was hoping it's something simple. Any help will be greatly appreciated.
I'm confused now... first you had halogens, now you have HID's?

EDIT: Late to the party again. Cwren already got it.
 

· Premium Member
Joined
·
17,303 Posts
Caren.
I just wanted to say Thank you for your help. You were right, alI I had to do was remove the adapter and all s well.

People like you make this site a great place to get straight answers with no b.s.
Happy to help though I'll wager there is a moderator on here who would argue the "no b.s. from cwren" point...
 

· Premium Member
Joined
·
17,303 Posts
Like the clip, not sure if used properly?
I tried to paste it starting at the appropriate part which is like 2.5 minutes in (where Gene Wilder grabs the chess piece really fast, the same scene in the photo thumbnail) but the board software doesn't process the link properly no matter which way I pasted it and I gave up trying.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top