Plow stopped working, then started to, ideas?

Discussion in 'Sno-Way Discussion' started by turbo38sfi, Feb 15, 2008.

  1. turbo38sfi

    turbo38sfi Senior Member
    Messages: 289

    Everything was working fine no problems. Went into the restaurant, came out and the plow wouldn't move. So change the batteries in my control, nothing. Tried 3 different sets, same thing. So had some ratchet tie downs and got the blade up so I could get it to walk up a snowbank and put the metal piece in place so I could get home.

    Got home, things worked. Could it be wet wires? I heard no clicking or anything when trying to move the blade. I unplugged it and plugged it back in, twisted it etc..nothing.
    It's a 1 yr old 26 series and I wasn't plowing when this happened..just driving.

    One thing I thought was odd and this is where I'm looking for ideas.
    When I would move the joystick, the power light would flash..that's normal. It did it with all sets of batteries I tried. The odd thing is that I hit the down pressure button and tried moving the joystick, the red down pressure LED went out and the orange power LED would flash. That is odd ?

    When I came home and it was working, I tried it again, when moving the joystick w/down pressure on, the orange LED would flash and the red led stays solid.

    Could I have lost radio communication temporarily??
  2. snowman2025

    snowman2025 Senior Member
    Messages: 144

    I had a buddy that was having a problem with his power connection where it plugged into the truck. Make sure it is in there nice and good and maybe get some di-electric grease on there.
  3. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,985

    Check your grounds, including the one on the pump block under the black cover. Then check your power plug for too much dielectric grease causing it to separate
  4. OP

    turbo38sfi Senior Member
    Messages: 289

    Ground to the battery, then ground under the pump cover. Any others other than those 2?
  5. toby4492

    toby4492 2000 Club Member
    Messages: 2,385

    I would agree on checking all ground and power connections for the plow. I would also inspect the battery holder inside the joystick. If the batteries aren't making good contact in the holder it could stop functioning also. Let us know what you find.
  6. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,985

    Wouldn't hurt to check the power side connections as well
  7. goose06

    goose06 Junior Member
    from NE Ohio
    Messages: 22

    Had some issues with mine earlier this season, would work intermittenly. Turned out to be a loose ground under the hood. Hand checked it and it seemed tight , tighten it down a little farther with a socket, problem solved. Been good ever since.
  8. stangman35

    stangman35 Senior Member
    Messages: 267

    Last edited: Feb 19, 2008
  9. Pearcelawn

    Pearcelawn Senior Member
    Messages: 368

    That was me. If you don't have the problem solved it could be worth a trip back to the restaurant just to eliminate that possibility. That whole thing was frying my brain for a while.:dizzy:
  10. nbenallo33

    nbenallo33 Senior Member
    Messages: 473

    i was gonna suggest that too i have seen that a couple of times where you get too much di-electric greese and when it gets cold it causes it to seperate