plow problems

martyman

Senior Member
Location
MARKHAM ONTARIO
I just switched over my mount and harness for my western 6.5 to my other jeep and I am sure that I have it all hooked up right. All the lights and the plow controller is on (only when the plow is hooked up) and it still doesn't seem to work. I have checked the ground and I am starting to think maybe the controller is mess up because the little red light on the controller worked before even if the plow wasn't hooked up. I hope that this makes sence.

Marty. thanks if you can help:eek:
 

Arc Burn

PlowSite.com Addict
martyman,check your selinoid(spelling) or motor relay,same thing,this has happened to my fisher twice,thay cost like $10-$15 and for what ever reason they do go bad.Make sure that motor relay is grounded correctly.Your lights will work even if the selenoid is bad,it just runs your electric pump.Hope this helps!
 
OP
M

martyman

Senior Member
Location
MARKHAM ONTARIO
thanks guys

I had no clue what else to check since I have never had a problem with this plow in the 3 years that I have owned it. I will check the joystick and the soloniod and the motor relay ground.

thanks and have a great snowplowing season. ( I still havn't got enough customers for this season)

Marty
 
OP
M

martyman

Senior Member
Location
MARKHAM ONTARIO
Nope

I was given an owners manual but not an installers manual. I took everthing off and drew a diagram the way it was on my other jeep and hooked it up the same way. I think that it must have something to do with the controller..but I am just guessing at this point. The controller light is works and I checked the motor and it seems fine and I have a new solonoid.

Marty thanks for your replies. I have my jeep booked for an appointment Nov26th if I can't figure it out by then..
 

snowplowjay

Banned
Location
Meriden CT
I had problems with keeping the lights on and the electrical working during a storm last year late at night with the western on my Jeep. Landed up all i needed was to give a little squirt of Die electrical grease on the connector plugs and my problems were solved.


Jay
 
:confused: i quesss im a little confused, the plow does'nt work when hooked up or the lights dont switch over. well if the plow does'nt work check the fuse that is in line with the controller. if you have a friend with a western you can try their controller to see if you have a change.
 
Guys......Also remember if you have a Fisher Fishstick
or Western Cab Command hand held controller.

There IS a SFE-6 glass tube fuse INSIDE the controller
and NOT in line.

Just in case your plow won't work check that.......But a
dark controller would clue you in !.............geo
 
Top