1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Plow controller wont turn on... i've tried two. a relay issue?

Discussion in 'Boss Plows Discussion' started by Ramairfreak98ss, Feb 16, 2012.

  1. Ramairfreak98ss

    Ramairfreak98ss PlowSite.com Addict
    Messages: 1,931

    straight 7'6" superduty plow on our f150 wont turn on the controller... we tried two different ones

    I checked the red/black line wire from under the dash "the key/ignition on wire" and i have voltage where its plugged in when truck is turned on.

    I check the same wire going into the solenoid under the hood and have power there, but that solenoid doesnt click or anything when i unplug it/replug it back in. I swapped it with the next solenoid over and same deal.

    What else should i be checking that would make this thing not fire up?
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Will the plow/truck headlamps switch over?

    Check the brown wire in the same relay socket for ground, should have it. You have power there and the relay only requires power and ground to trip.

    Be sure to check the plug closely for corrosion as well while you're in there.
  3. Ramairfreak98ss

    Ramairfreak98ss PlowSite.com Addict
    Messages: 1,931

    Checked the brown wire.. all connections in/out of each relay have power once i put a wire in between for the first solenoid.. if i leave the first solenoid in, all still has power too when truck is on/ignition on.

    How can i manually test to trip the solenoid? i dont think its working, i put positive to the smaller of the 4 terminals and it doesnt click, but that wouldnt make the controller not come on right?
  4. Ramairfreak98ss

    Ramairfreak98ss PlowSite.com Addict
    Messages: 1,931

    Alright, replaced the solenoid.. installed a new one, cant get it to "click" like its supposed to, even after i hotwire the positive lead to the small terminal "white wires' it doesnt trip... have the plow hooked up and nothing, no clicks or anything.

    I turned on lights and flipped plow light switch, nothing, always on truck lights.
    Means that solenoid isnt turning on either.

    Fuses are good, near the solenoid, the small 5 amp red fuse has power in the connection when ignition is on too

    I cleaned the connection 9 pin end inside the truck where the controllers hook up and put dielectric on it, still nothing. Could i have a broken wire somewhere? But wouldnt most functions still operate or at least turn on?

    Whats going on?
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    If you already went so far as to replace the motor solenoid and trigger it with a hot wire on the white stud and it didn't work then the only thing left there is ground. As in the brown ground feed, same one on the motor solenoid as well as all the relays in the relay pack, it's all the same circuit. So you'll want to double check that and verify you have ground everywhere before going after anything else..
  6. Ramairfreak98ss

    Ramairfreak98ss PlowSite.com Addict
    Messages: 1,931

    So the brown wire is the ground on the solenoid and relays... all browns should be ground? thanks
  7. contractor078

    contractor078 Senior Member
    Messages: 232

    i had the same problem re wire under my dash had come un done. did you check all of your fuses as well? i think there is well one under dash and 4 under hood. hope you get it worked out looks like we may get something this weekend. good luck let us know how you make out.
  8. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Correct, all brown wires are common together and all are ground.