1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

no power to plow

Discussion in 'Truck & Equipment Repair' started by Sealer People, Nov 28, 2009.

  1. Sealer People

    Sealer People Senior Member
    Messages: 210

    hi guys,

    i just got my plow back. went in for service.

    i take it home last night & it was ok (up, down sideways etc)

    this morning, i start the truck, raise the plow& drive for half hour

    i get back, the plow wont go side to side, nor will it go up any higher.

    So I push forward on the joystick & she goes down.
    & now thats it!!!

    No power, at all anywhere. Its plugged just fine, although theres alot of grease on the connections.

    I checked the fuses & nothing is burnt but theres a small little kink in one red wire leading from the engine fuse box that goes into the truck fuse box.

    The lights on the plow work, but no power to the plow .

    Its a blizzard 7600 LT
    Truck is a 96 chevy 2500 diesel.

    The plow was just serviced & they told me all was good.

    Any advice ?????
  2. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Do you hear the solenoid click or motor run?
  3. Mark Witcher

    Mark Witcher Senior Member
    Messages: 605

    Clean off all the grease on the main plug to start with. Likely not getting power thru the main battery connection. Wiggle it around and try different positions. May also need to spread the main battery connector pins in the plug to get a good contact.
  4. Sealer People

    Sealer People Senior Member
    Messages: 210

    I dont hear the solenoid click at all.

    Its just dead.

    Im going to try sprayong some terminal cleaner on the main plugs.

    BRB. lol Tis the season.!!!
  5. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    bad connection somewhere. get the cables out.
  6. beam

    beam Senior Member
    from pa
    Messages: 314

    check the switchs on the side make sure in right position and turn key on and off to reset same for controller
  7. Sealer People

    Sealer People Senior Member
    Messages: 210

    Hi, I just checked to make sure it was plugged in ok & it is,
    I sprayed terminal cleaner cause the plugs were filled with grease & still nothing.

    However, when I click the joystick to the right, I do hear a click but nothing else for left, up or down.

    Any takers on this one???
    Still no power. I thought for sure the terminal cleaner would work.
  8. Gbettner

    Gbettner Junior Member
    Messages: 17

    I'm gonna say soleniod,soleniod ground,or small wire to solenoid not properly connected. You would be hearing a loud solenoid clicking if it was working.

    Have you tried jumping solenoid with a screwdriver to diagnose?
  9. Sealer People

    Sealer People Senior Member
    Messages: 210

    I'm not the most experienced with this stuff.

    How do you jump a solenoid ?

    I checked the cable & the grounds are connected tight.

    Note: theres no power at all, not even to the " power hitch " that electrically mounts on to the truck.
  10. beam

    beam Senior Member
    from pa
    Messages: 314

    check the battery connections make sure all pins are lined up