1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

No float????

Discussion in 'Fisher Engineering Discussion' started by 512high, Feb 17, 2014.

  1. 512high

    512high Senior Member
    Messages: 136

    Hello, have a MM1, new controller, new rams, inside wiring new etc, plow hasnt been used in a few weeks....IT GOES UP, LEFT AND RIGHT AND GOES DOWN...I hold the joystick down for float, went to the frame to push down, wont budge!! any ideas??? thamks ahead of time..
  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 4,681

    Does float light come on? If so, push harder.
  3. 512high

    512high Senior Member
    Messages: 136

    contoller is type mounted to dash...not handheld.....its new
  4. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,288

    Did you collapse the lift ram when it was cold?I had snow and ice on my headgear and when it was really cold I couldn't get the headgear pins to go into pushplates so I lifted the plow and went to collapse the piston and it was frozen.Did the piston collapse when you first replaced it?Your ram nut could also be to tight try and loosen it alittle
    Last edited: Feb 17, 2014
  5. 512high

    512high Senior Member
    Messages: 136

    Problem Solved! Thank you to those that responded...Called my Fisher Person that I deal with, after making sure the controller was not the issue(I swapped from another truck etc) He suggested "loosen" Ram nut, squirt Pb Blaster, Fluid film etc, then push down on it....it worked!! He said do that several times, then tighten up packing nut "snug"....seems fine!!!