1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

New to plowing - plow will only angle to left

Discussion in 'Truck & Equipment Repair' started by Hershe, Dec 3, 2007.

  1. Hershe

    Hershe Junior Member
    from Maine
    Messages: 1

    I have Diamond plow and is using the MD II mount with the E-60H power units. It worked last year and this is the first time I'm using it this year. I hooked up the plow and tried to lift the blade using the Electro - Touch Remote by tapping the Up Button. The following result happened:
    Red LED comes on and the plow angled to the left. I reset the remote by turning remote off and then back on. I next tried to pushed the L Button and I can hear a motor noise but nothing happens. I then pushed the Down Button and got the Red LCD light so I reset the remote. I then pushed the R Button and got the Red LCD light. Any suggestions as to what my problem could be or what can I try to diagnosis the problem?
    Last edited: Dec 3, 2007
  2. big bird

    big bird Senior Member
    Messages: 119

    is there oil in it first good thing to look at :cry:
  3. DeereFarmer

    DeereFarmer PlowSite Veteran
    Messages: 3,296

    Looks like you are only going to be plowing to the left. No seriously, start with the easy things. Check the oil, maybe flush it if you want. Check the connection pins, all the wiring, and then for dumb things like it could be binding on something. Start simple and work from there. Keep us up to date with what you find. I'm not too familiar with Diamonds.
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    I can assure you it's an electrical problem....

    Either the controller is dying...(happen's all the time on the touch pads)

    Or you have a poor or corroded connection somewhere in the harness...

    Check the small orange ground wire first.. it should be connected directly to the battery.

    Next is the battery cable connections both on the battery and at the connecting plug on the plow.

    Also check the same connecting plug for corrosion or a broken pin. The MDII connector plugs are a real problem and love to corroded and fall apart inside.

    Check the connections on the plow also, there will be one on each coil and the two battery cables on the motor..

    If it still has the black rubber pump cover on it...ditch it, they cause more harm than good..
  5. turfcowboy

    turfcowboy Junior Member
    from ohio
    Messages: 2

    Why does the black rubber pump cover do more harm than good
  6. 92XT

    92XT Senior Member
    Messages: 343

    is the coupling secure??? check relay. fuse. fluid
  7. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    "Why does the black rubber pump cover do more harm than good"

    B&B I got this one :)

    What happens with the cover is, The pump will sweat due to the pump being warm from running, and the cold air. With the cover on, it traps water between the cover and the pump, If you take it off, the air from drivng will dry of the pump.

    Just like the Lights,Pump, and Coil wires, you should never tape them up., Same this happens water, gets traped in them and causes problems.

    I had the same problem last year, Keep getting the red Over load light, it was during a big snow, so after omost a hour going over every thing, I just pulled a new wiring Harn. off the shelf and put it on fast, never had a problem since.
  8. Syoung8

    Syoung8 Junior Member
    Messages: 1

    Check the ground cables, I just had this same problem this morning. The overload light would turn on and the plow would just quit, the motor solenoid would still click but the pump would not run. So i jumped the pump off the battery to make sure it didn't just die and it still ran so after several frustrating minutes I discovered it was the ground cable so i just hooked up my jumper cables to a ground under my hood and to the pump and it worked fine, now I just have to clean up my connections and it will be good as new. Your problem sounds very similar. Check your grounds and see if it clears it up.