1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

New Meyer SV2 Issue

Discussion in 'Meyer / Diamond Products Discussion' started by SnowHill11, Nov 30, 2013.

  1. SnowHill11

    SnowHill11 Senior Member
    Messages: 104

    Hey everyone, i purchased a new Meyer SV2 plow this fall and after this first storm I have an issue. (its under warranty and I will be going that route, but would like to trouble shoot it in order to transport to my dealer and hour away.)
    The plow started to intermittently not raise or lower. Then occasionally some of the other functions started to act up. I washed the plow down and when I went to leave I had no plow functions. Only the solenoid would continually click and then stop. I checked over the connections under the hood and they look good. Then I pulled the main plug and found an issue. The outer wire wrap has been rubbed off the harness and a black wire inside is rubbed about a third of the way through. I assumed it had been shorting so I pulled it away from the steel it was rubbing on. I still have no function and the solenoid still clicks, could having a few strands missing in this wire increase the resistance enough to keep the plow from functioning or did something else likely burn up? I had to strap/short chain it home.
  2. maxwellp

    maxwellp PlowSite.com Addict
    Messages: 1,123

    Is power going though the solenoid? Or even getting there?
  3. SnowLane

    SnowLane Senior Member
    Messages: 127

    Run a jumper cable from the battery ground to the black ground wire of the motor for the hydraulic unit. This should make it work temporarily.
  4. SnowHill11

    SnowHill11 Senior Member
    Messages: 104

    This is the newer V-70 pump. Without anything jumping anything the red LED monitor light on the control blinks constantly. With a jumper wire from the negative battery terminal to the negative motor terminal the light blinks twice on start up. If you try any of the controls the controller just shuts off.
  5. jb1390

    jb1390 Senior Member
    Messages: 710

    Check the pins on the connector for the controller and truckside harness. My V2 connector had the ground pin push out of the connector. I replaced the connector with a more rugged military style connector I got from work, problem solved forever.

    My ground pin pushed out, and from what I remember, the symptoms were very similar.

    If your plow is the same as mine, the connector is a Molex Minifit Jr. Replacement pins ( and connector shells) are cheap. For lots of cycles on this particular connector-many people fill the back of the connector with epoxy to help hold the pins in place.
  6. jb1390

    jb1390 Senior Member
    Messages: 710

    I missed originally that you said that the plow would not lower. If that is true-the contactor is fine, as it will not be used to lower the plow. If the problem is with all functions, I think your problem will be found in the ground wire (think it is black) of the controller, right at the connector between controller/truck.
  7. SnowHill11

    SnowHill11 Senior Member
    Messages: 104

    Well took it in to the dealer and they replaced the plow side harness and that fixed it, apparently the wire was rubbed through enough to either not flow enough amps or have to much resistance and generally mess all functions up....
    Glad to have it back in working order, hope to really try it out this weekend!