1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

New 810 Blowing Fuses

Discussion in 'Blizzard Plows Discussion' started by lawnMaster5000, Dec 22, 2006.

  1. lawnMaster5000

    lawnMaster5000 Senior Member
    Messages: 105

    Sorry this is rather long but I am in desperate need of some help trouble shooting a problem with my brand new 810PP. Thanks for your assistance.

    I have a Blizzard 810 with about 18 hours of use on it. After Plowing for 18 hours with no problems (other than a lose hose improperly installed by the dealer) my plow began blowing fuses to the controller. At first it was just one, replaced, then the plow worked for about 10 more minutes. Then the fuse blew again, replaced, plow worked for 5 minutes. Blew again, plow worked for 1 minute. Replaced again and then every time I would attempt to raise the plow the fuse blows. In every case I was trying to raise the plow when the fuse blew - all other functions work without a problem.

    Having just purchased this plow i was not familiar with how to lock the plow in the up position and the owners manual gave no assistance but I eventually found where the "extra" pin goes and got the plow up so I could move the truck.

    I figure there is a short in the lines so i trace the lines through the entire path and find no exposed wires or possible shorts. I next decide maybe there is water in the connection, clean and dry all connectors, still blows the fuse every time. I eventually give up and hire someone to finish my plowing for me and I parked the plow in the garage.

    After speaking with Blizzard Tech Support they suggest replacing the lift coil. I order the part from my dealer - and waited 13 days for it to arrive. When it arrived i found out I was shipped a coil for some other plow. The one I received is not used anywhere on my plow.

    Very frustrated I decide to try my plow again just for the h*ll of it. It WORKS. I play with it a bit going up and down then it started doing the same thing as before. Blew more fuses (10-20 amps). Just like last time the interval got shorter till the plow wouldn't budge UP again. Luckily the down works so i was able to take it off the truck.

    I Contacted Blizzard Support who was not helpful and only was able to suggest taking the plow to the dealer or replacing all the wiring. My Dealer is 4 hours away, taking the plow there is not an option.

    I try testing a few things by connecting the wire harness to the truck and leaving the plow away from the truck and powering the attach/detach toggle switch a few times. Eventually after a while it started blowing fuses just as before. I then decide to disconnect the connector to the coils, to my surprise the fuse still blew every time I tried to "raise" the plow. I then decided to disconnect the plows electrical from the truck and try the controller in the truck without the plow being connected - well the fuse never blew.

    This tells me the problem is somewhere on the plow side. Please help me figure out what could be happening here and how i can fix it. Thanks for your help.

    Scott M
    St. Louis, MO
  2. Jerre Heyer

    Jerre Heyer Senior Member
    Messages: 948

    Scott, Water in the plug at the front, pinched wire in the plow side harness or blown diode plug in pack could cause your problem. Water in the plug is the big one/ Ice in there turns to water and shorts between pins in the plug.

  3. magnatrac

    magnatrac PlowSite.com Addict
    Messages: 1,059

    I have an idea as to your problem I just got rid of my 03 810 and I had your exact problem twice. the first time I had a coil that was all rusty and I replaced it with a new one that was weather proof( it came with two rubber o rings), the next season I had the same problem blowing fuses to the controler only on the up function. My dealer told my it was because of rusty plow pins. So after some time on the phone with tech support they told me that I had to replace the valve on the up function, I no longer have my 810 manual to tell you which coil and valve it is. I beleive that your plow is to new to have that fail so I would pull that coil off of the valve and clean it. just an idea ,I wish I had more detailed info. Call your dealer because that plow is too new.
  4. lawnMaster5000

    lawnMaster5000 Senior Member
    Messages: 105

    Heyer, Originally I had thought the same thing as you about water in the plugs. But I did all I can to let them dry out including letting it sit in a heated garage for over two weeks.
    - What is the "diode plug in pack"? and how would i go about testing that? Would that only affect the up function?

    Magnatrac, I too thought it was the coil so I was able to isolate the coil and test it individually - never encountered any problems. I then removed the coil from the system all together and left the circuit open. The fuse would still blow at the controller.

    I guess there has to be a short somewhere in the plow side wire harness. I am going to try and get my dealer to ship me a new harness but I cant afford for that to take another 13 days like the last part I ordered.

    If you have other ideas please let me know

    Thanks again for all your help.

    Scott M
  5. appleman

    appleman Junior Member
    Messages: 10

    What truck do you have the plow mounted to?
  6. cowboysfan

    cowboysfan Junior Member
    Messages: 24

    Was going to ask the same thing,you beat me to it,maybe we should start calling you speedy.xysport
  7. lawnMaster5000

    lawnMaster5000 Senior Member
    Messages: 105

    The 810 is mounted on an '06 Chevy 2500HD with Dmax with plow prep.

    Are you guys thinking that the problem may be on the truck side?
  8. appleman

    appleman Junior Member
    Messages: 10

    If the harness comes through the bumber you could have a cut wire.If you reach in behind the bumper you will feel a razor sharp edge.
    We had a harness short out in this location. We now add a section of wire loom in this area to prevent rubbing.
  9. cowboysfan

    cowboysfan Junior Member
    Messages: 24

    Any news on what was causing the problem?
  10. lawnMaster5000

    lawnMaster5000 Senior Member
    Messages: 105

    I still have not found a cause for the problem.
    Blizzard Tech Support and my Dealer have given suggestions but still haven't been able to direct me to the proper tests to isolate the problem

    My biggest problem in testing is that the problem only occurs after the system "warms up" and I am not able to reproduce the problem consistently.

    I have run through about 20 fuses (both 10&15 amp) trying to test things.

    I purchased an electronics multi-tester and tested the voltage loss at several points in the line. I found nothing unusual. I also tested the resistance of the wires and found nothing inconsistent from one line to another.

    If anyone has any further suggestions please let me know.

    If there is anyone is StL that has a controller that I can try or even let me hook up to your plow that would be very appreciated.


    Scott M
  11. cowboysfan

    cowboysfan Junior Member
    Messages: 24

    did you get a new harness yet?
  12. lawnMaster5000

    lawnMaster5000 Senior Member
    Messages: 105

    i have run several tests on the plow side harness and havent been able to find anything unusual. The dealer says they dont want to just send me a bunch of parts.

    I am thinking that I may just buy a new plow side harness and new controller swap them for the old ones and see if it fixes the problem. After I find the problem I will return the damaged purchased parts for a refund.

    I hate doing things that way but I dont know what else to do at this point.
  13. cowboysfan

    cowboysfan Junior Member
    Messages: 24

    Thats not how u should have to do it, maybe another dealer will step up and help u out,its a new plow,theres dealers reading this,step up to the plate and help this guy.:help:
  14. Mark Witcher

    Mark Witcher Senior Member
    Messages: 605

    I had a problem with a Boss plow blowing fuses a while back. It turned out to be that I had put too much dielectric grease on the main plug and it was shorting out between the terminals.
  15. lawnMaster5000

    lawnMaster5000 Senior Member
    Messages: 105

    Interesting problem with the grease. Is there any way to test to see if that is what is causing my problems. I thought the purpose of the grease was to prevent that type of short from occuring as well as minimizing the corosion?

    I suppose an easy test would be to clean all terminals and see if I still encounter the problem.

    Today when I spoke with Blizzard tech support I was informed that DD tech support now handles all Blizzard problems. Unfortunately DD Support is not familiar with the Blizzard system and the only thing they have to go off of is the owner's manual. Needless to say they have been little to no help.

    Thanks for the input everyone.
  16. lawnMaster5000

    lawnMaster5000 Senior Member
    Messages: 105

    Hopefully I will get something figured out this week. I spoke with an electrical engineer over the weekend and he was able to give me some guidance.

    I will keep you all informed. Thanks for the help thus far.
  17. lawnMaster5000

    lawnMaster5000 Senior Member
    Messages: 105

    Blizzard has finally agreed to send me a full wire harness both truck side and plow side. I am going to Install the plow side first since it is as easy as changing a few connectors.

    If that fixes the problem I will jump for joy. If not then I will lay out the truck side without a full install and hope I can eliminate the problem using the new harness.

    I am going to send the problematic or unused parts back to my dealer.

    If I cant get it figured out still I guess I will have to take a trip to Chicago.
  18. cowboysfan

    cowboysfan Junior Member
    Messages: 24

    Sorry to here it took this long to get some action,but hopefully one or the other will solve your problem.GOOD LUCK.
  19. SnowDozers

    SnowDozers Member
    Messages: 86

    Just throw in a 100 amp fuse and look for fire.
  20. lawnMaster5000

    lawnMaster5000 Senior Member
    Messages: 105

    i put a 30amp in there, thought about the 100 though