my brake lights-Heeelp

scientist

Junior Member
Location
california
I cant seem to get my brake lights to work the running lights work but thats it, i even changed the switch at the pedal still nothing so, I was going to run new lines from switch to lights but i dont know which or how to hook it up with the switch being that i think some of the wires are wrong because my turn signals dont work either and one of them stays on on the dash but not in the rear of the truck its a 73 chevy 1/2 ton with utility bed can some one please help i wanted to do this myself because the shops wanted like 350.00:confused:
 

wxmn6

PlowSite.com Addict
Location
Claverack, NY
Not sure if it could be related, but could it be the fuses? I'd try to narrow down the problem by checking the fuses. If they are fine, then I don't know what else to tell you.
 

karl klein

Senior Member
Location
omaha,ne
i dont think it's the switch. the brake lights and the turn signals run off of the same wire so i would recomend tracing the wires from the hood back to the tail lights. i feel it would be very hard to figure out were the wires go in the cab. on my 77' chevy i had the same problem and what was a matter was the insulation on the wires was so dry it was cracking off and sorting out. i replaced the wires from under the hood back with a wiring kit for a trailer.

good luck
 

85chevy3/4

Junior Member
Location
kansas city
I had the same problem on my 85 3/4 4x4. I had no brake lights, parking lights or turn signals. They would show on the dash and they still didn't work. It turned out it was the ground wire in my left rear tailight. There is one wire that is either on the right or left side where the harness plugs into the back of the light. Mine didn't get a good connection because of the newly painted bed. I cleaned it off with a wire brush and everything works fine now. Hope this helps.
 

Top Forums

Similar threads

Similar threads

Top