Snow Plowing Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Good day everyone,
I have a MVP Plus that is not working. First the controller light was blinking, found a broken + wire in harness and repaired. The light is now on steady. The blade will not move any direction, tested motor relay, have + on big lug and nothing on other big lug, + on both small. If I hit motor relay small +(red) with neg it will move commanded by remote up, vee, scoop etc but not down, I hit lower small with - (black)it will power down the blade. I checked wiring from control mod to motor relay for shorts, both +(red)/-(black) and seem fine. Besides a module control i am not sure where else to look?
Harry
 

· Registered
Joined
·
8,557 Posts
Fleet flex works be switching the ground side of the circuit. First I suggest you stop putting power or ground to anything while plow module is connected. There should be fuses out on the plow, check them. It does sound like you lost ground to the plow thou. You can test by using jumper cable to hook negative on plow motor to negative on battery then try control. If this works you most likely have a bad power harness or ground on pump.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I've checked all fuses and they are intact. I've grounded the plow, the motor to check for ground but nothing changes. I jumped + big lugs and motor does work. I've checked ground to motor, ground to plow module in plug A and all solid. It seems the control module is not transferring ground out to the motor relay when commanded. I've taken the small -black off and tested while using controls and it does not switch to neg, same with +red.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
It was blinking at first, found harness near 4 lead plug near light module red wire corroded and broken. Fixed line and light stayed on steady but plow would not move plow module clicked. Chased all power and ground wires no issues, plow module replaced with new for $229 And plow works like a charm.
Thx
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top