1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Motor Spins, No Blade Movement

Discussion in 'Fisher Engineering Discussion' started by Bmxdkj, Feb 4, 2010.

  1. Bmxdkj

    Bmxdkj Member
    Messages: 57

    Hi, I have a Minute Mount 2 with the Insta-Act Pump, the pump motor spins, but no plow movement. The plow was used to make 3 passes and stopped working, however the plow is about 5 years old. I took the canister off where the pick-up and filter are and those are all intact and also clean, however as a precautionary measure I cleaned the filter, but still no movement. I have no idea where to start looking and seeing whats wrong with this thing. Any help or ideas is greatly appreciated!
  2. rebert

    rebert Senior Member
    Messages: 106

    Id bet money that the pick up fell off in the tank. It happen to mine last year, fisher sells a bracket to fix it so it wont fall of any more.
  3. Bmxdkj

    Bmxdkj Member
    Messages: 57

    The pick-up was all there, nothing fell off inside of the tank. Thank you for the quick reply!
  4. chris694205

    chris694205 Senior Member
    Messages: 175

    my ezv did this the other day.. it turned out to be some clogged/stuck valves.. the motor would spin but nothing would happen.... the pump sounded like it was havin trouble spinning
  5. Bmxdkj

    Bmxdkj Member
    Messages: 57

    How did you unclog them? I tried tapping on them with a small hammer but nothing....
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You have a control issue. Start with check for magnetism on the coils, think you'll find there isn't any. Thus equaling bad controller, corroded grill connector, or lost ground wire on the coils.
  7. Bmxdkj

    Bmxdkj Member
    Messages: 57

    I took the pump apart today and found that there was a broken gear inside of the pump. Hope this helps anyone with the same problem I have had.