1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

MM2 3 plug wont move, need help.

Discussion in 'Fisher Engineering Discussion' started by lpstroker, Nov 29, 2014.

  1. lpstroker

    lpstroker Junior Member
    from C
    Messages: 10

    I have a Minute Mount 2, 3 Plug that will not work. The lights on the plow work, but the plow will not move up or angle. The red light on the joy stick is on. When I try to move the plow I hear a clicking but it sounds like it's under the dash, but I followed the harness and it just goes through the firewall, then the harness splits. I tested the solenoid on the fender I have power coming in from the battery on one big lug (Put test light from from - on battery to big lug) then I tested the other big lug (same way and the other lug) had nothing when I hit the switch. I tested the two small lugs on the solenoid (put the test light to the + of the battery and then to the each lug.) The light was lit prior to hitting the switch on one lug and when I hit the switch the light flickered. The other lug stayed lit the whole time. I checked the in line fuses (a 7.5 amp and a 15 amp) and the fuses were good and had power on both sides. I tried and extra solenoid I had, and still no results.
  2. lpstroker

    lpstroker Junior Member
    from C
    Messages: 10

    I just went out to look at something and fired up the truck and noticed that the light on the controller lit up prior when I just turned the key to the on position prior to starting the truck, after the truck was started the light went out for about 30-seconds, then came back on. I tried to raise the plow and it worked. I angled the blade and that worked. I returned the blade to its straight position, then tried to angle it again and it did not work. The head lights dimmed and then the truck head lights came on. When I let off the controller the truck lights went off and the plow lights came back on. While I was trying to angle the blade and it didn't work I could hear a clicking sound that sounded like it was in the dash (Like a relay clicking on and off.) I also noticed that when I tried to angle the blade and it did not work the battery light on the truck came on.
  3. kimber750

    kimber750 PlowSite Veteran
    Messages: 4,681

    Check grounds but sounds like plow motor is on its way out.
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,395

    Ground. X2
    Also relook at your solenoid. Something sounds fishy.
  5. NHresident

    NHresident Senior Member
    Messages: 304

    u want to make sure that the red wire that comes into the cab that's about 1 foot down from the controller plug is fused an attached to only KEYED on power
  6. lpstroker

    lpstroker Junior Member
    from C
    Messages: 10

    It is hooked to a 10 amp fuse. I have to check the book to see what that fuse goes too. What does that red wire power? The controller?
  7. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,288

    Yes the red wire powers the controller.Should be hooked into a 12 volt key on power source.I have an inline fuse for mine and its hooked into the cruise control fuse
  8. mrv8outboard

    mrv8outboard Senior Member
    Messages: 205

    It sounds like the solenoid. Was you spare one brand new? You can check it out the old fashion way, just jump the two big lugs with the shaft of a screw driver (be very careful, sparks and things get hot) and see if the motor runs. Most likely the solenoid.
  9. lpstroker

    lpstroker Junior Member
    from C
    Messages: 10

    Ended up being a bad battery terminal end. It was a junction looking thing that look like it was a factory battery terminal cable end. The solenoid was getting a enough juice to light up a test light but not enough to run the plow. I put a marine battery terminal to the battery post and put new terminal ends on all the cables and bam, all fixed. Thanks for the help.