Snow Plowing Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, im new here. I was plowing this morning, 0°farenheit, and in the middle of a driveway the plow wouldn't raise. Lifted it with a heavy duty strap to get ot home. Tightened the battery ground, put some dielectric grease on main power plug and it worked again, but with plow lights on, controller sometimes strobed on and off instead of working. While plowing my shop lot, headlights cut out, then a miuite later complete plow power loss. Jumping the selonoid fires up the pump. Any ideas would be appreciated
 

· Premium Member
Joined
·
17,303 Posts
Hi, im new here. I was plowing this morning, 0°farenheit, and in the middle of a driveway the plow wouldn't raise. Lifted it with a heavy duty strap to get ot home. Tightened the battery ground, put some dielectric grease on main power plug and it worked again, but with plow lights on, controller sometimes strobed on and off instead of working. While plowing my shop lot, headlights cut out, then a miuite later complete plow power loss. Jumping the selonoid fires up the pump. Any ideas would be appreciated
Check the wire going to the ignition fuse at the truck fuse box. See if its loose
 

· Registered
Joined
·
146 Posts
DISREGARD
missed the jump solenoid part on org post.

same issue here on one truck other day, make sure no dielectric grease INSIDE the connectors on contacts.
ours was the 2 wire connector had been greased too much and collected crud on truck side.
cleaned it, works fine even in below 0 weather.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top