1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Looking for help

Discussion in 'Introduce Yourself to the Community' started by stan3ley, Feb 5, 2015.

  1. stan3ley

    stan3ley Junior Member
    from Mi.
    Messages: 24

    Hi guys,
    I am not a newbie to plowing, been doing it in different capacity's for over35 years.
    I have a problem, I bought a Western UniMount that was pretty beat up.
    I am having problems with the pump system. I had a mount installed and the truck side wired by a installer. I plugged in my first joy stick and burned up the circuit board. The motor was rusted and completely seized. Inside the housing I could see water. Took it completely apart, pumped out the rams bought new lines took out the pump and the solenoids. I took out the cartridges and cleaned and inspected them. The screen was clogged and had ripped open. I took the pump and ran it in a can of new oil to pump out any remaining crud. The solenoids where in spec for ohms. put them back together an cycled them in clean with 12 Volts to check operation and clean them, all was fine. Put it all back together and bought another joystick.
    Every thing worked well for the first plowing, about 3 hrs. worth. The motor relay was sticking at times, went and got a replacement, the aftermarket one. Worked ell after that. Next snow fall, I am about an Hr. into plowing and the plow stars twitching going from left to right. Then the new relay starts sticking in the off position again, tap it lightly and all is good. Then the plow wont raise, but moves left and right. Then it goes up but in up it doesn't want to go L or R, drop it and it moves L & R. I try to go up and it goes to the right and stays, now movement at all. I get it to the shopand start testing, pump runs, check solenoids with test light, all solenoids light when joy stick is moved. I pulled the pump and put it on the bench, separated the motor and case. The magnet inside is covered in goo, and the screen is plugged. I think there is still crap inside the valve manifold block.
    Every screw and plug was rusted on this case. I welded allen wrenches to the plugs to remove them. I didn't remove the poppet valves or the relief valves the first time apart. The poppet valve covers are smashed flat, and I don't know if the screw out or pry out. The manual said hit with hammer to aid in removal ???
    That's where I am at. I have had the help of a few generous guys guide me through this so far, Thanks guys.
    Can someone tell me if those poppet valves screw out and if so if I weld a nut on them will I ruin something inside ?
    Sorry for being long winded, just trying to convey all that's been done so far.
    Thanks for being here.
  2. jhenderson9196

    jhenderson9196 Senior Member
    Messages: 615

    You need to post this in the proper place for it to attract the attention of those familiar with your plow. Go to the Western forum down the main page.
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,391

    Stan I said in the other thread to test light the coils per there proper function, and you reply back with something about an ohm meter and the solenoid?
    I also gave you the unimount manual in the other thread that you never replied to.
    If you want to continue to start new threads all time and not actually preform any of the tests we are asking you to do, then do so. That's not proper etiquette.