1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

lift cylinder wont float on fisher plow

Discussion in 'Commercial Snow Removal' started by kingstos, Aug 20, 2004.

  1. kingstos

    kingstos Junior Member
    Messages: 6

    I'm new to the forum but already getting ready for the winter. I have a 7 1/2 fisher minute mount sehp plow on a 1999 chevy z71 1/2 ton pickup. I put plow on truck to take out of garage and wash. I brought back in garage but could not get lift cylinder to go down all the way. It worked fine, up and down left and right but when putting fish stik in float (hold a few seconds on down button) it must not have worked because cylinder would not go down so I could remove blade. I ended up draining fluid and having to loosen large nut where piston goes into cylinder. This released pressure and piston went down. I will be buying fresh fluid and putting back together soon. Any idea on most common cause? fish stik itself? any troubleshooting help would be most appreciated. thanks for the advice ahead of time.... .steve
  2. Arc Burn

    Arc Burn PlowSite.com Addict
    Messages: 1,141

    Hook it up again and loosen the nut and wipe some fluid on the ram and run the plow up and down with the nut a little loose,do this a few times to try and lube the packings inside the cylinder.
    If that doesn't work,pick up a packing kit and new wiper seal from your dealer(under $20 bucks for everything) and repack the cylinder.
  3. neversatisfied

    neversatisfied Member
    from ct
    Messages: 73

    On the truck side electricals there are the 2 plugs.One for the power/ground.The other is for the controller wires.Put the fishstick in float,and go to the controller plu outside and wiggle it,just stay clear of the blade dropping.Mine has done this before.There was supposedly a wire that gets messed up in there.I even went out and bought a new plug for that side.It solved the problem but came back.This has happened to me on a few of our fishers.Seems a bad connection in the wire plug.I think u can buy just the plug end and splice it in nice and neat.Hope this helps.
  4. kingstos

    kingstos Junior Member
    Messages: 6


    thanks for the responses, both replies would make more sense if I was having trouble with the lift cylinder going up and down. I am not , I tried for 30 minutes having it go up, down many times withouit a problem. It is just the final 2 or 3 inches to get piston all the way down will not work. Sorry if I do not see the solution yet, do you guys still think it may be what has been previously replied ? Thanks again for the support ....steve
  5. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    I'm with Arc Burn, Packings are dry or packing nut is to tight.
  6. kingstos

    kingstos Junior Member
    Messages: 6

    OK, I'm going to order the fluid and try it, any good spots online to buy fisher factory parts? thanks
  7. kingstos

    kingstos Junior Member
    Messages: 6

    thanks to everyone for help, I changed fluid and it worked!, I think packing nut was too tight, that probably caused issue. thanks again