1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

I need help with 810

Discussion in 'Blizzard Plows Discussion' started by james1115, Dec 14, 2010.

  1. james1115

    james1115 Member
    from CT
    Messages: 81

    My A frame latch wont move with my toggle switch up or down, When I go into my truck and hit the plow up button the a frame latch moves and grabs the mount and lifts up but then it is stuck on my truck until I pull out the S8 solenoid to relive pressure and pry the A arm off to be able to get the plow off. What could this be? is it possible to be a bad S5 or S8 solenoid? what about the main HD solenoid? bad toggle switch? please help me start to eliminate things because I don't feel like spending tons of money on parts I don't need.
    Thanks guys
  2. lilweeds

    lilweeds PlowSite.com Addict
    Messages: 1,178

    Toggle switch is cheap and probably what is wrong, so give that a shot first.
  3. ppetroska

    ppetroska Junior Member
    Messages: 5

    Try cleaning your harness plug first and use some fresh dielectric grease. The other day, my plow would raise but wouldn't go down and cleaning the plug solved the problem.
  4. james1115

    james1115 Member
    from CT
    Messages: 81

    I will try both of those things. I think the toggle(one that i replaced) is a cheaper toggle then the one blizzard provides. It sounds like it is hydrolocked when I try and use the toggle for both up and down. I hear the motor kick in but no movement. I wish I had the control pad that can drop the a frame latch mine just will raise it by lifting the plow. Tomorrow I am going to change the fluid and remove the hydr fluid housing(something I have never done) in 5 years and check the filter/screen underneath. Could this be the problem?
  5. IMAGE

    IMAGE Sponsor
    Messages: 1,747

    I had a problem with an 810 that wanted to go UP no matter what function I did. Confused the heck out of me, replaced the diode, checked and double checked wires and cleaned grounds. It turned out to be a bad control box. (had the big shoe box) . Easiest way to check is borrow a friends controller and see if it still does it.

    I had the same problem with a RT2 Boss that did the same thing... and it turned out to be a bad controller also. Electrical problems suck imo.
  6. babs2972

    babs2972 Junior Member
    Messages: 23

    Mine did the same thing and after replacing selenoids it turned out to be my toggle switch.
  7. james1115

    james1115 Member
    from CT
    Messages: 81

    so I switched solenoid S5 and S7 and it made no difference so then I swapped S6 and S8 and it is fully functional. I have no idea what that did but whatever it did it worked lol
  8. Mark Witcher

    Mark Witcher Senior Member
    Messages: 605

    If the toggle switch goes out you can still mount and dismount the plow with the cab controller. Put plow in float and you can push on the grab latch to lower it.
  9. damian

    damian Senior Member
    Messages: 330

    be carefull swapping the toggle switch with a look alike. i havent been able to locate a suitable aftermarket replacement for that one yet you may have a switch that is not correct.also check the diode pack in the plow harness.