1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Hiniker Plow Help! Any ideas?

Discussion in 'Hiniker' started by timtpa, Dec 16, 2010.

  1. timtpa

    timtpa Member
    Messages: 56

    Today when I was out, I would go to raise the blade, but the plow would continue to raise even after I tried to stop it mid-way. When i went to lower it, it would not fall freely to the concrete, but would slowly float to the ground! I could actually hear the motor continue to run after the plow would continue to raise as high as it would go! This happened 8-10 times today, but would allways go back to working correctly after a few minutes. Any ideas? This is a 7 1/2 straight plow and has allways worked great!
    Also, i did a fluid change a few weeks ago. My dealer told me Hiniker took 2.5 quarts of hydro fluid, but mine would only take about 1.75 quarts. Which is correct? Ive done a search for both, but found nothing. Thank you for the help! Tim
  2. Eggie329

    Eggie329 Senior Member
    Messages: 123

    Sounds like the solenoid is ready to go soon. I had a Western keep running and it turned out to be the solenoid. As for it not taking all the fluid could it have had some oil left in the angle cylinders after you drained it? Good luck!
  3. NBI Lawn

    NBI Lawn PlowSite.com Addict
    Messages: 1,797

    I say solenoid as well. They are only like $30
  4. timtpa

    timtpa Member
    Messages: 56

    Thanks everyone. Do you think it would be the solenoid or is it possible to be the solenoid coil?
  5. D2 Cat

    D2 Cat Junior Member
    Messages: 24

    1 and 1/2 quarts is correct by Hiniker operator's manual, page 26 under specifications.
    Last edited: Dec 18, 2010
  6. doyles

    doyles Member
    Messages: 95

    it is the solenoid there is no coil