1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice


Discussion in 'Boss Plows Discussion' started by dfdsuperduty, Dec 31, 2009.

  1. dfdsuperduty

    dfdsuperduty Senior Member
    Messages: 597

    :help::help: I bought a used 8'2" V has been working just fine took the blade off the truck hadn't had it on in a couple of days tried to put it on today and nothing can't even manually push the light tower up can hear the motor trying to work etc... any and all help will be appreciated tried to check the hydro fluid but can't get the cover off because of the lift cylinder being forward :help::help: Hope everyone has a safe and Happy New Year!!!!
  2. grandview

    grandview PlowSite Fanatic
    Messages: 14,609

    Did you put the control in float?
  3. jkiser96

    jkiser96 Senior Member
    Messages: 401

    If the lights are working then try checking the fluid level. If the lights are not working then start running down wires &Z start with teh ground wires.
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Assume it was in float when you tried to manually attach? If so and it still wouldn't I'd be looking for a dirty or ice covered pins on the bumper connector. Because in the float position it should attach itself or if it won't at least allow you to do it manually.

    Must be old enough that it doesn't have an external fill/check port.

    If you need to remove the pump cover whether the light tower is raised or lowered you pull the top pin out of the lift cylinder to allow space for cover removal.
  5. dfdsuperduty

    dfdsuperduty Senior Member
    Messages: 597

    Thanks for the help guys I am going to give it a shot and see what happens
  6. dfdsuperduty

    dfdsuperduty Senior Member
    Messages: 597

    I think the cyl. was air locked. I bled of the cyl. lifted it manually and it has worked like a champ