1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice


Discussion in 'Commercial Snow Removal' started by dodgethis0103, Jan 1, 2005.

  1. dodgethis0103

    dodgethis0103 Junior Member
    Messages: 5

    OK I Just installed my :gunsfiring: BRAND NEW snoway on thursday and everything worked fine. I kept it on my truck on friday and it also worked fine. This morning I had it in the garage and needed to move it so I hooked up turned the remote on and nothing happened at all. That's right it would not move not even a heartbeat (the motor doesn't run). My dealer is closed till monday not that i can get it there anyway. :help: Does anyone have any ideas?
  2. Mick

    Mick PlowSite.com Veteran
    from Maine
    Messages: 5,546

    I don't know anything about Sno Ways, but does the power supply have a fuse? Have you tried going to the Sno Way site to see if they have an online diagnostic manual?
  3. dodgethis0103

    dodgethis0103 Junior Member
    Messages: 5

    I already checked ther fuse and it is fine. It kinda works now but not consistent. I have the wireless controller so i am going to try replaceing the batteries to see if that helps. :confused:
  4. dodgethis0103

    dodgethis0103 Junior Member
    Messages: 5

    Batteries don't make a difference
    For you Sno-way guys i am about to sound pretty stupid but ....

    There is a silver post comming out of the top of the manifold, when you press it with your finger you can get things to work. There is absolutly no mention of this in the manual. If anybody knows how to fix this or what it is please give your .02